A numerical model for snow avalanches in research and practice

User Manual v1.7.0

AVALANCHE

WSL-Institut für Schnee- und Lawinenforschung SLF
WSL Institut pour l’étude de la neige et des avalanches SLF
WSL Instituto per lo studio della neve e delle valanghe SLF
WSL Institute for Snow and Avalanche Research SLF

Eidgenössische Technische Hochschule Zürich
Swiss Federal Institute of Technology Zurich
Title picture: Vallée de la Sionne, WSL

Contributors (alphabetical order)

**SLF/WSL:**
Perry Bartelt
Yves Bühler
Marc Christen
Yolanda Deubelbeiss
Maren Salz
Maike Schneider
Lina Schumacher

Manuscript update

November 2017
# Table of Content

1  Introduction ............................................................................................................. 1  
   1.1  Motivation ........................................................................................................ 1  
   1.2  RAMMS ........................................................................................................... 2  
   1.3  Learning by doing ............................................................................................. 3  
2  Installation and Setup .............................................................................................. 4  
   2.1  System requirements ......................................................................................... 4  
   2.2  Installation ......................................................................................................... 4  
   2.3  Licensing .......................................................................................................... 11  
   2.4  First start .......................................................................................................... 11  
      2.4.1  Personal license request file ........................................................................ 12  
      2.4.2  Getting the personal license key ................................................................. 12  
   2.5  Update .............................................................................................................. 13  
3  Setting up a simulation ............................................................................................ 14  
   3.1  Preparations ..................................................................................................... 14  
      3.1.1  Topographic data - Digital Elevation Model (DEM) .................................. 14  
      3.1.2  Project and Scenarios ................................................................................ 15  
      3.1.3  Release information .................................................................................. 15  
      3.1.4  Friction information .................................................................................. 15  
      3.1.5  Global parameters ..................................................................................... 19  
      3.1.6  Forest information ..................................................................................... 19  
      3.1.7  Calculation parameters ............................................................................. 19  
   3.2  Preferences ...................................................................................................... 20  
   3.3  Creating a new project ...................................................................................... 22  
   3.4  Working with the RAMMS GUI ....................................................................... 26  
      3.4.1  Visualizing shapefiles, MuXi-files and domain-files .................................. 26  
      3.4.2  Changing maps and orthophotos (aerial images) ........................................ 28  
      3.4.3  Moving, resizing, rotating, viewing ............................................................ 29
6.1 References ........................................................................................................89
6.2 Publications .....................................................................................................89
7 Appendix ..........................................................................................................89
7.1 MuXi-Table .....................................................................................................89

List of figures ........................................................................................................92
List of tables ..........................................................................................................95
Index ......................................................................................................................96
CHAPTER 1: INTRODUCTION

1 Introduction

In the field of natural hazards there is an increasing need for process models to help understand the motion of geophysical movements. These models allow engineers to predict the speed and mass of hazardous movements in complex terrain. Such models are especially helpful when processing mitigation measures, such as avalanche dams or snow sheds. Hazard mapping is an especially important application in Switzerland and other mountainous countries. An accurate prediction of runout distances, flow velocities and impact pressures in general three-dimensional terrain is the driving motivation for the development of dynamical mass movement models. Although helpful and well-liked by users, one-dimensional models such as AVAL-1D require that the primary flow direction and flow width must be defined by the user in advance. This is often difficult, especially in open terrain, or in terrain consisting of several possible flow channels. Furthermore, flow interaction with catching and deflecting dams cannot be accurately modeled using one-dimensional simulation codes.

RAMMS (Rapid Mass Movements Simulation) is a two-dimensional, state-of-the-art numerical simulation model to calculate the motion of geophysical mass movements (snow avalanches, rockslide, debris flows and shallow landslides) from initiation to runout in three-dimensional terrain. It was designed to be used in practice by hazard engineers who need solutions to real, everyday problems. It is coupled with a user-friendly visualization tool that allows them to easily access, display and analyze simulation results. New constitutive models have been developed and implemented in RAMMS, thanks to calibration and verification at full scale tests at sites such as Vallée de la Sionne. These models allow the application of RAMMS to solve both large, extreme avalanche events as well as smaller mass movements such as hillslope debris flow and shallow landslides.

RAMMS was developed by the RAMMS program team at the WSL Institute for Snow and Avalanche Research SLF. This manual describes the features of the RAMMS program – allowing beginners to get started quickly as well as serving as a reference to expert users.

The RAMMS web page http://ramms.slf.ch provides useful information such as a forum, frequently asked questions (FAQ) or recent software updates. Please visit this web page frequently to stay up to date!

1.1 Motivation

Mitigation of natural hazards relies increasingly on numerical process models to predict the area inundated by rapid geophysical mass movements. These movements include

- snow avalanches,
- torrent based debris flows and hillslope debris flows,
- mudslides,
- ice avalanches and glacier lake outbreaks
- rockfalls and rock avalanches.

Process models are used by engineers to predict the speed and reach of these hazardous movements in complex terrain. The preparation of hazard maps is a primary application. The models are especially helpful when proposing technical mitigation measures, such as dams and embankments or rockfall
CHAPTER 1: INTRODUCTION

protection barriers. The models allow hazard engineers to optimize limited financial resources by studying the influence of different hazard scenarios on defense options.

1.2 RAMMS

The RAMMS (RApid Mass Movements Simulation) software system contains three process modules:

- RAMMS::AVALANCHE
- RAMMS::DEBRISFLOW
- RAMMS::ROCKFALL

The RAMMS::AVALANCHE and RAMMS::DEBRISFLOW modules are designed for flow phenomena containing fast moving particulate debris of snow and rocks. In the avalanche module, the interstitial fluid is air, whereas in the debris flow module the interstitial fluid is mud. The RAMMS::AVALANCHE and RAMMS::DEBRISFLOW models are used to calculate the motion of the movement from initiation to runout in three-dimensional terrain. The models use depth-averaged equations and predict the slope-parallel velocities and flow heights. This information is sufficient for most engineering applications. Information in the slope-perpendicular direction (e.g. mass and velocity distribution) is lost; however, this is seldom of practical interest. Both models require an accurate digital representation of the terrain. Engineers specify initial conditions (location and size of the release mass) and friction parameters, depending on terrain (e.g. roughness, vegetation) and material (e.g. snow, ice or mud content of the debris flow).

The RAMMS::ROCKFALL module is used to study the rigid body motion of falling rocks. The model predicts rock trajectories in general three-dimensional terrain. Rock trajectories are governed by the interaction between the rock and ground. The model contains six primary state variables: three translational speeds and three rotational velocities of the falling rock. From these, kinetic energy, runout distance and jump heights can be derived. Generalized rock shapes are modeled. Rock orientation and rotational speed are included in the rock/ground interaction. The RAMMS::ROCKFALL module is therefore fundamentally different from the RAMMS::AVALANCHE and RAMMS::DEBRISFLOW modules because it is based on hard-contact, rigid-body Lagrangian mechanics, not Eulerian flow mechanics. It also differs from existing rockfall modules because the rock/ground interaction is not governed entirely by simple rebound mechanics, but frictional (dissipative) rock/ground interactions. These govern the onset of rock jumping. The RAMMS::ROCKFALL module predicts all rigid-body motions – rock sliding, rolling, jumping and skipping.

In all RAMMS modules, new constitutive models have been developed and implemented, thanks to calibration and verification at full scale test sites such as St. Léonard/Walenstadt (rockfall, mitigation measures), Vallée de la Sionne (snow avalanches) and Illgraben (debris flow). At present, a new scientific RAMMS module is under development: RAMMS::EXTENDED.
1.3 Learning by doing

This manual provides an overview of RAMMS::AVALANCHE. Exercises exemplify different steps in setting up and running a RAMMS simulation especially in Chapter 3 ‘Setting up a Simulation’. However, to get the most from the manual, we suggest reading it through while simultaneously having the RAMMS program open, learning by doing. We assume RAMMS users to have a basic level of familiarity with windows-based programs, commands and general computer terminology. We do not describe the basics of windows management (such as resizing or minimizing). RAMMS windows, click options and input masks are similar to other windows based programs and can be used, closed, reduced or resized in the same way.

DISCLAIMER

RAMMS is intended to be used as a tool to support experienced users. The interpretation of the simulation results has to be done by an avalanche expert who is familiar with the local as well as with the topographic and geological situation of the investigation area. In no event shall SLF/WSL be liable for any damage or lost profits arising, directly or indirectly, from the use of RAMMS. Swiss law applies. Court of jurisdiction is Davos. If you encounter problems, please contact ramms@slf.ch.
CHAPTER 2: INSTALLATION AND SETUP

2 Installation and Setup

2.1 System requirements
We recommend the following minimum system requirements for running RAMMS::AVALANCHE:

- Operating Systems: Windows 7, 8 and 10 (64-bit)
  32-bit systems (Win XP) are not supported and recommended anymore
- RAM (memory): 4 GB (more recommended)
- CPU: > 1 GHz, 2 cores or more recommended
- Disk space: ca. 220 MB needed for the software

2.2 Installation
Please download the RAMMS::AVALANCHE setup file “ramms_user_setup_64.zip” from http://ramms.slf.ch (Downloads section). We recommend to install RAMMS on a 64-bit Windows system (Windows 7/8/10).

Direct download link: http://ramms.slf.ch/ramms/downloads/ramms_user_setup_64.zip

Please do the following steps before beginning to install RAMMS:

- Click on the path given above or copy the path to any browser. A window pops up and the automatic download of the file ramms_user_setup_64.zip starts after clicking Yes.
- Unzip the file to a temporary location.
- You must have Administrator privileges on the target machine. If you do not have such privileges, the installer cannot modify the system configuration of the machine and the installation will fail. Note that you do not need Administrator privileges to run RAMMS afterwards.
- Read first, install afterwards! Please read the whole installation process once, before you begin the installation.
- Start the file “ramms<version>_user_setup_64.exe”.


CHAPTER 2: INSTALLATION AND SETUP

Step 1: Welcome

The welcome dialog introduces you to the English setup program and will guide you through the installation process. Click Next to continue.

![Welcome dialog](image1)

Figure 2.1: Installation - welcome dialog window.

Step 2: Readme

Short introduction to RAMMS. Click Next to continue.

![Readme dialog](image2)

Figure 2.2: Installation - Readme dialog window.
CHAPTER 2: INSTALLATION AND SETUP

Step 3: Accepting the license agreement

Read the license agreement carefully and accept it by activating the check box in the lower left corner. If you do not accept the license agreement, you are not able to proceed with the installation. After accepting the license agreement, click Next to continue the installation.

![Figure 2.3: Installation - license agreement dialog window.](image)

Step 4: Select destination directory

Choose your destination directory. This dialog shows the amount of space available on your hard disk and required for the installation. Beware: Do NOT use a blank or special character within your installation directory path name (e.g. C:\program files\RAMMS is not allowed, use C:\Programme\RAMMS or C:\Programs\RAMMS instead). Click Next to start the installation process.

![Figure 2.4: Installation - destination directory dialog window.](image)
CHAPTER 2: INSTALLATION AND SETUP

Step 5: Installing the files

RAMMS is copying the files to the destination location. The window shows the installation progress.

![Figure 2.5: Installation - installing files dialog window.](image)

Step 6: Finished installing the files

RAMMS finished copying the files. Click Next to finish the installation process.

![Figure 2.6: Installation - finished installing files dialog window.](image)
CHAPTER 2: INSTALLATION AND SETUP

Step 7: RAMMS installation finished!

RAMMS successfully finished the installation. Click Finish.

![Figure 2.7: Installation - finished installation dialog window.](image)

Step 8: Welcome to IDL Visual Studio Merge Modules

To ensure that all important system libraries are installed on your target machine follow the instructions below:

The welcome dialog introduces you to the English setup program and will guide you through the installation process of the IDL Visual Studio Merge Modules. Click Next to continue.

![Figure 2.8: IDL Visual Studio Merge Modules - welcome dialog window.](image)
CHAPTER 2: INSTALLATION AND SETUP

Step 9: Ready to install the program

![Figure 2.9: IDL Visual Studio Merge Modules - ready to install the program.]

Click Next to continue.

Step 10: Installing IDL Visual Studio Merge Modules

The wizard is installing the files. Please wait until it is finished.

![Figure 2.10: IDL Visual Studio Merge Modules - installing...]

CHAPTER 2: INSTALLATION AND SETUP

Step 11: InstallShield Wizard Completed

The wizard completed the installation. Click Finish.

![Installation - destination directory dialog window.](image)

Figure 2.11: Installation - destination directory dialog window.

After having successfully installed RAMMS and the necessary files on your personal computer, you will notice the RAMMS icon on your desktop (for all users):

![RAMMS icon.](image)

Figure 2.12: RAMMS icon.

Additionally, a new application folder is created in Start → Programs (for all users):

- RAMMS → Run RAMMS
- RAMMS → Uninstall RAMMS

![RAMMS program group](image)

Figure 2.13: RAMMS program group
2.3 Licensing

Access to RAMMS is controlled by a personal use license. Personal use licenses are time limited licenses tied to a single personal computer. This method of licensing requires a machine’s unique host ID to be incorporated into a license request file. After the license request file is sent to SLF/WSL, you will receive a license key. Entering the license key on a personal computer enables full RAMMS functionality for the specific personal computer. For more information please visit http://ramms.sfl.ch.

2.4 First start

Double-click the RAMMS icon or use Start → Programs → RAMMS → Run RAMMS to start RAMMS for the first time. Whenever you start RAMMS, the splash screen below will pop up:

![RAMMS start window](image)

Click on the image. It will disappear and RAMMS will start up. The following dialog window appears (Figure 2.15 RAMMS Licensing):

![RAMMS licensing window](image)
CHAPTER 2: INSTALLATION AND SETUP

2.4.1 Personal license request file

Click the button to create your personal license request file. In Figure 2.16 enter your full name and the name of your company.

In the next dialog window, choose the destination directory of your personal license request file and save it to your target machine. Your personal license request file should look similar to Figure 2.17.

2.4.2 Getting the personal license key

You find an order form on the RAMMS web page (Order Form or Demo Order Form) at http://ramms.slf.ch. Fill in all your personal information, choose the license period, license type and number of licenses you wish to order, attach your personal license request file(s), accept the license agreement and click Submit Order.

An order confirmation email is sent to your email address. We then process your order and send you an invoice. As soon as we received your payment, we will send you your personal license key. Your personal license key is named similar to A V A_20151013_TestName_RAMMS_TimeLicense.txt. Open the file in a text editor. It should look similar to Figure 2.18 below.
CHAPTER 2: INSTALLATION AND SETUP

Now, restart RAMMS (as explained before). The IDL splash screen appears (Figure 2.14) and then the dialog window of Figure 2.15 shows up (RAMMS - Licensing). Copy the license key (in this example: AVALANCHE agjk-hmih-ik1u-jk42-l1h3) and paste it at the field LICENSE KEY (see Figure 2.15). Notice that there is the prefix AVALANCHE. This prefix is part of the license key and has to be inserted as well! If RAMMS accepts your installation key, you successfully finished the installation.

2.5 Update
When you start RAMMS it will automatically check for updates on the internet. This can lead to an error message, if your firewall blocks the executable idlrt.exe (this file starts the IDL-Virtual Machine you need to run RAMMS). Please unblock this file for your firewall. You can also disable the AutoWebUpdate-function by unchecking Help → Advanced... → AutoWebUpdate. In the same way you can enable the AutoWebUpdate-function by checking Help → Advanced... → AutoWebUpdate.
3 Setting up a simulation

3.1 Preparations

To successfully start a new RAMMS project, a few important preparations are necessary. Topographic input data (DEM in ASCII-, XYZ- or GEOTIFF-format), project boundary coordinates and georeferenced maps or orthophotos should be prepared in advance (.tif format and .tfw-file, maps and orthophotos are not mandatory, but nice to have). Georeferenced datasets have to be in the same Cartesian coordinate system (e.g. Swiss CH1903 LV03) as the DEM. Polar coordinate systems in degree (e.g. WGS84 Longitude Latitude) are not supported. For more information about specific national coordinate systems please contact the national topographic agency in your country.

3.1.1 Topographic data - Digital Elevation Model (DEM)

The topographic data is the most important input requirement. The simulation results depend strongly on the resolution and accuracy of the topographic input data. Before you start a simulation, make sure all important terrain features are represented in the input DEM. RAMMS is able to process the following topographic data:

1. ESRI ASCII grid (Figure 3.1)
2. ASCII X, Y, Z regular, single space data (Figure 3.2), irregular data not supported!
3. GEOTIFF (georeferenced information embedded within a TIFF file)

The first two data types are also available e.g. from www.swisstopo.ch. ASCII X, Y, Z data can be converted within RAMMS into an ESRI ASCII grid. Beware, that the XYZ-data must be regular!

The header of an ESRI ASCII grid must contain the information shown below in Figure 3.1.

Conversion into ESRI ASCII grid

An ESRI ASCII grid can be created in ArcGIS with the function ArcToolbox → Conversion Tools → From Raster → Raster to ASCII. In RAMMS it is possible to import regular ASCII X, Y, Z single space data and convert the data into an ESRI ASCII grid (using Track → New... → Convert XYZ to ASCII Grid).
Irregular XYZ data

Irregular XYZ data cannot be converted directly in RAMMS.

3.1.2 Project and Scenarios

A project is defined for a region of interest. Within a project, one or more scenarios can be specified and analyzed. For every scenario, a calculation can be executed. A project consists therefore of different scenarios (input files) with different input parameters. The basic topographic input data is the same for every scenario. If you want to change the topographic input data (e.g. change the input DEM resolution or the project boundary coordinates) you have to create a new project. Other input parameters (such as release area, calculation domain, calculation grid resolution, end time or time step) can be changed for every scenario.

![Figure 3.3: The same project extent (area of interest) can be used to calculate different scenarios with different input parameters.](image)

3.1.3 Release information

The definition of release areas and release heights have a very strong impact on the results of RAMMS simulations. Therefore we recommend to use reference information such as photography, PGS measurements or field maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area.

Users can use any polygon shapefile as a release area, see section 3.5.1 on page 35. Release areas drawn in RAMMS are saved as polygon shapefiles and can be easily imported in GIS-Software (e.g. ArcGIS). Shapefiles created in e.g. ArcGIS can be used in RAMMS.

3.1.4 Friction information

RAMMS employs a Voellmy-fluid friction model, which is based on the Voellmy-Salm approach (we refer to Salm et al. 1990 [3] and Salm 1993 [4]).
CHAPTER 4: RESULTS

Physical friction model

The physical model of RAMMS::AVALANCHE uses the Voellmy friction law. This model divides the frictional resistance into two parts: a dry-Coulomb type friction (coefficient $\mu$) that scales with the normal stress and a velocity-squared drag or viscous-turbulent friction (coefficient $\xi$). The frictional resistance $S$ (Pa) is then

$$S = \mu N + \frac{\rho g u^2}{\xi} \quad \text{with} \quad N = \rho h \cos(\phi)$$

where $\rho$ is the density, $g$ the gravitational acceleration, $\phi$ the slope angle, $h$ the flow height and $u$ the vector $u = (u_x, u_y)^T$, consisting of the avalanche velocity in the x- and y-directions. The normal stress on the running surface, $\rho h \cos(\phi)$, can be summarized in a single parameter $N$. The Voellmy model accounts for the resistance of the solid phase ($\mu$ is sometimes expressed as the tangent of the internal shear angle) and a viscous or turbulent fluid phase ($\xi$ was introduced by Voellmy by using hydrodynamic arguments). The friction coefficients are responsible for the behavior of the flow. $\mu$ dominates when the flow is close to stopping, $\xi$ dominates when the flow is running quickly.

Throughout one simulation the friction coefficients of a calculation domain are constant. However you have the possibility to add up to two polygons within the calculation domain with different friction parameters (see section 3.5.4 “How to run a calculation” on page 48.)

The Voellmy friction model has found wide application in the simulation of mass movements, especially snow avalanches. For modeling snow avalanches the Voellmy model has been in use in Switzerland for many years and a set of standard parameters is available.

Yield stress

Since Version 1.6.20 the basic Voellmy equation has been modified to include a yield stress (cohesion). Many materials, like mud and snow, do not exhibit a simple linear relation ($\mu = \text{constant}$), see Figure 3.4. To model yield stress, we introduce the parameter $N_0$. With this approach it is possible to model ideal plastic materials. In this case $N_0$ serves as a yield stress and $\mu$ a “hardening” parameter. The new equation for the frictional resistance $S$ is then

$$S = \mu N + \frac{\rho g u^2}{\xi} + (1 - \mu)N_0 - (1 - \mu)N_0 e^{-\frac{N}{N_0}}$$

where $N_0$ is the yield stress of the flowing material. Unlike a standard Mohr-Coulomb type relation this formula ensures that $S \to 0$ when both $N \to 0$ and $U \to 0$. It increases the shear stress and therefore causes the avalanche to stop earlier, depending on the value of $N_0$.
CHAPTER 4: RESULTS

Curvature

Since Version 1.6.20, the normal force $N$ includes centrifugal forces arising from the terrain curvature. We use the method proposed by Fischer et al. (2012) which was specifically developed for RAMMS. The centrifugal acceleration $f$ is both a function of the avalanche velocity and terrain curvature. The acceleration is calculated according to

$$ f = uKu^T $$

The matrix $K$ describes the track curvature in all directions, including the track “twist”. The centrifugal force is then

$$ F = \rho hf $$

which is added to the normal force $N$. Typically this increases the friction, causing the avalanche to slow down in tortuous and twisted flow paths. It can change the location of the deposition once the flow leaves the gully. Curvature may be activated/deactivated in the Run Simulation window (tab Params) or via the menu ‘Help → Advanced… → Curvature’.

Figure 3.4: Relation between normal and shear stress. Left: Yield stress $N_0$ serves to increase the shear stress for higher normal pressures. At low normal pressures (small flow heights) the shear stress increases rapidly from $S=0$ to $S=N_0$. The slope of the ‘$S$ vs $N$’ relation remains $\mu$, when the normal pressures are large. Right: If $\mu=0$, we have a visco-plastic behaviour.
CHAPTER 4 : RESULTS

Friction parameters $\mu$ and $\xi$

RAMMS::AVALANCHE offers a constant and a variable calculation mode. If a calculation is done with constant friction values, of course, no terrain undulations and forest areas are considered. Therefore we suggest to use the variable friction values if possible. An automatic RAMMS procedure classifies friction values ($\mu$ and $\xi$) based on topographic data analysis (slope angle, altitude and curvature), forest information and global parameters return period and avalanche volume (see Figure 3.6). $\mu$ and $\xi$ values are saved as ASCII files (called MuXi-files) and can be easily imported in GIS-Software (e.g. ArcGIS).

How to create a new MuXi-file is demonstrated in the exercise 3.5e “How to create a new MuXi-file” on page 47.
CHAPTER 4 : RESULTS

3.1.5 Global parameters

The friction values $\mu$ and $\xi$ strongly depend on the global parameters return period and avalanche volume (see MuXi-table on page 89). Therefore an appropriate return period has to be defined and the avalanche volume has to be checked under Input $\rightarrow$ Global Parameters prior to creating a new MuXi-file (see Figure 3.6 and exercise “How to create a new MuXi-file” on page 47).

3.1.6 Forest information

Forest information is not required for a successful simulation, but recommended, because the friction parameters strongly depend on forest information. Forest information can be provided as:

- ESRI ASCII grid (0: no forest, 1: forest)
- Polygon shapefile

If no such files are available, the user can draw a polygon shapefile in RAMMS and import it as forest information (see section 3.5.3 on page 44).

3.1.7 Calculation parameters

Calculation parameters such as output name, simulation grid resolution, end time, time step etc. can be changed interactively in the RAMMS Run Simulation Widget.
CHAPTER 4 : RESULTS

3.2 Preferences

Before starting to work with RAMMS, be sure to set your RAMMS preferences and place the necessary DEM (Digital Elevation Model) files as well as the forest files, maps and georeferenced orthophotos you wish to use in the appropriate folders defined in the preferences see Figure 3.7 and Figure 3.8 below.

Use Track → Preferences to open the RAMMS preferences window or click the button . For resetting the general preferences use Help → Advanced… → Reset General Preferences.

General Tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working Directory</td>
<td>Set your working directory. VERY IMPORTANT: DO NOT USE BLANKS in the working directory path!</td>
</tr>
<tr>
<td>Map Directory</td>
<td>Set the folder where you place your georeferenced digital maps (consists of a .tif file and a corresponding .tfw file (world-file)).</td>
</tr>
<tr>
<td>Orthophoto Directory</td>
<td>Set the folder where you place your digital georeferenced orthophotos (aerial picture, consists of a .tif file and a corresponding .tfw file (world-file)).</td>
</tr>
<tr>
<td>DEM Directory</td>
<td>Set the folder where you place the Digital Elevation Models (format ASCII grid, see section 3.1.1 on page 21)</td>
</tr>
<tr>
<td>FOREST directory</td>
<td>Set the folder where you place your forest-files (formats: ASCII grid or polygon shapefile).</td>
</tr>
</tbody>
</table>
CHAPTER 4 : RESULTS

Avalanche Tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nr of colorbar colors</td>
<td>Set default nr of colorbar colors.</td>
</tr>
<tr>
<td>GIF-Animation Interval [s]</td>
<td>Set interval for GIF animation images.</td>
</tr>
<tr>
<td>Background Color</td>
<td>Set background color (greyscale between 0: black and 255: white).</td>
</tr>
<tr>
<td>Animation Delay [s]</td>
<td>Set animation delay to decelerate the animation speed.</td>
</tr>
</tbody>
</table>

The following exercise Working directory shows how to choose a new working directory. All further settings can be changed in a similar manner. The settings are saved, until they are changed again manually.

Exercise 3.2 : Working directory

Choosing the right working directory is very useful and saves a lot of time searching for files and folders.

VERY IMPORTANT: Do NOT use blanks or special characters in the path names!

- Click  (or use Track → Preferences or Ctrl+P) to open the RAMMS preferences window.
- Click into the field Working directory. A window pops up where you can choose your new working directory. Click OK in both windows. Do this also for other directories if necessary.

Figure 3.9: RAMMS preferences

Figure 3.10: Browse for the correct folder.
CHAPTER 4 : RESULTS

3.3 Creating a new project

A new project is created with the RAMMS Project Wizard, shown in the exercise below. The Wizard consists of four steps:

<table>
<thead>
<tr>
<th>Exercise 3.3: How to create a new project</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Click or Track → New... → Project Wizard to open the RAMMS Project Wizard.</td>
</tr>
<tr>
<td>- The following window pops up.</td>
</tr>
</tbody>
</table>

![Figure 3.11: RAMMS Project Wizard Step 1 of 4](image-url)
CHAPTER 4: RESULTS

Continuation of exercise 3.3: How to create a new project

Step 1:
- Enter a project name (1)
- Add project details (2)
- The project location (3) suggested is the current working directory. To change the location click into the Location field. A second window appears and you can browse for a different folder (see figure below).
  
  VERY IMPORTANT: Do NOT use BLANKS or special characters in the project location path!
- Click Next (4)

![Figure 3.12: Step 1 of the RAMMS Project Wizard](image1)

![Figure 3.13: Window to browse for a new project location.](image2)

Step 2:
- Locate your DEM-file (ASCII or GEOTIFF) in the folder set in the RAMMS preferences. Click into the corresponding field to browse for the appropriate file (1).
- The grid resolution of your DEM-file is shown in (2). Change the resolution, if needed (bilinear interpolation).
- Click Next (3).

![Figure 3.14: Step 2 of the RAMMS Project Wizard: GIS Information.](image3)
Continuation of exercise 3.3: How to create a new project

Step 3:
- Enter the X- and Y-coordinates of the lower left and upper right corner of your project area, using the Swiss Coordinate System CH1903 LV03 (or another Cartesian coordinate system), as it is shown below for the Vallée de la Sionne area.
- RAMMS shows the coordinates of your DEM-file (1).
- You can clip the DEM by entering new boundary coordinates or by specifying a polygon shapefile (2).
- Click Next (3).

Figure 3.15: Project coordinates: lower left and upper right corner of project area.

Figure 3.16: Step 3 of the RAMMS Project Wizard: Project Boundary Coordinates.

Step 4:
- Check the project summary.
- To make changes click Previous, to create the project click Create Project.

Figure 3.17: Step 4 of the RAMMS Project Wizard: Project Summary.

Project creation:
- The creation process can take a while. Different status bars will pop up and show the progress of the project creation process.
The following files will be created in the project folder.

![Figure 3.18: Created project files](image)

Table 3.1: Listing of files and directories created with a new RAMMS::AVALANCHE project.

<table>
<thead>
<tr>
<th>File / Folder</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc (folder)</td>
<td>Folder containing input and output log files</td>
</tr>
<tr>
<td>logfiles (folder)</td>
<td>Project creation and calculation log files</td>
</tr>
<tr>
<td>dhm.asc</td>
<td>ASCII grid with altitude values</td>
</tr>
<tr>
<td>dhm.sav</td>
<td>Binary altitude information (used in RAMMS)</td>
</tr>
<tr>
<td>_.av2</td>
<td>Input file</td>
</tr>
<tr>
<td>_.dom</td>
<td>Calculation domain ASCII file</td>
</tr>
<tr>
<td>_.dom.shp</td>
<td>Calculation domain shapefile</td>
</tr>
<tr>
<td>_.dom.shx</td>
<td>Calculation domain shapefile</td>
</tr>
<tr>
<td>_.dom.dbf</td>
<td>Calculation domain shapefile</td>
</tr>
<tr>
<td>_.xyz</td>
<td>Topographic data used in RAMMS</td>
</tr>
</tbody>
</table>
3.4 Working with the RAMMS GUI

Once the project is created, there are several useful tools which can be helpful when working with RAMMS. They are explained in the exercises below.

3.4.1 Visualizing shapefiles, MuXi-files and domain-files

There are different ways to visualize your project files (shapefiles, MuXi-files, domain-files). In the exercise below, we will show these possibilities.

**Exercise 3.4a : Visualizing shapefiles, MuXi-files and domain-files**

a. *Files tab in the right panel:*

- Click on the *Files* tab in the right AVALANCHE panel.
- In the file tree below, you will see your available project files (polygon shapefiles, MuXi ASCII files and domain shapefiles).

![Figure 3.19: Files tab and available project files (file-tree, dashed red). With the blue + button, files from external directories can be added to the file-tree. Refresh the tree with the refresh-button.](image)

- Click the checkbox next to a filename and the file will be shown in your visualization.

![Figure 3.20: Selected file (Release.shp) on the right is shown in the visualization.](image)
You can select and visualize as many files as you like!

**Shapefile properties**
- Line thickness, color or linestyle can be adjusted for every individual shapefile. These properties are only saved within this RAMMS Session. Right-click on a filename and choose *Shapefile properties*:

![Figure 3.21: Right-click menus Shapefile properties, Release properties, Import forest from shapefile, Deposition analysis (only output) and Delete.](image)

Figure 3.22: Use *Shapefile properties* to change line thickness, color or linestyle.

**Release properties**
- Please see section 3.5.1 on page 35 on how to specify release area properties.

**Import forest from shapefile**
- Please see section 3.5.3 on page 44 on how to import forest from a shapefile.

**Deposition analysis**
- This function is only available in output mode. Please see section 4.2.3 on page 61 on how to do a deposition analysis.

**Delete**
- Delete a file from disk.
b. Adding files to the project

You can add files to the visualization using one of these options:

- Add data: Use the button 🍂 or the menu ‘GIS – Add data’ to add a shapefile. If this shapefile is located outside of your project directory, it will be added to the files-tree.

- Add files from folder: Use the button (Add files from external directory) below the file-tree to add all the files from an external directory to the file-tree. These files are added during this RAMMS session. After you exit and restart RAMMS, you have to add the files again.

- Drag & Drop: see next section.

c. Drag & Drop:

It’s possible to Drag & Drop the following files onto the main visualization window:

- Input files (.av2)
- Output files (.out.gz)
- MuXi files (.asc)
- Polygon shapefiles (.shp)
- Domain shapefiles (.shp)

3.4.2 Changing maps and orthophotos (aerial images)

It is possible to change the map or orthophoto of a project anytime. Take into account, that the corresponding .tfw-file (world-file) has to be in the same folder as the actual map (.tif). If this is not the case, the map will not be found!

To check which map and orthophoto are currently loaded in the project, open the project input (or output) log (Project → Input Log File). Next to map image and ortho image you will find the location and name of the loaded map and image, respectively.

Exercise 3.4b : How to add or change maps and orthophotos

d. Add or change a map:

- Go to Extras → Add/Change Map or click 🍂.
- If more than one map is found, the following window pops up, listing the maps found:
CHAPTER 4: RESULTS

Figure 3.23: Window to choose map image.

Information on the image cover ratio (Percent), image dimensions (X- and Y-Dim, pixel) and size (in MB) are provided and might be a selection criterion.

- Select the map you wish to add and click **Load selected map**.

**e. Map not found:**
- If the question "No map found, continue search?" appears, you either don’t have an appropriate map, the map-folder directory is set wrong or the map is saved in a different folder. In the second case click **Yes** and choose the correct folder. A window pops up to browse for the correct map location and file.
- Or click **No** to cancel search.

**f. Change orthophotos:**
- Go to **Extras → Add/Change Image** or click 🌍.

### 3.4.3 Moving, resizing, rotating, viewing

**Exercise 3.4c: Moving and resizing the model**

**a. Terrain model has a dimension of 100% or smaller:**
- By clicking on the **arrow** 🚭 the model can be moved and resized.

Figure 3.24: Active project with lines and corners for resizing.
To move the model without changing size or aspect ratio, move the cursor to the model and check if the cursor turns to 🔵. Then click and hold the left mouse button and drag the model to the desired position.

To resize the model without changing the aspect ratio, use the mouse wheel to zoom in or out. Alternatively, you can resize the model by changing the percentage value in the horizontal toolbar 📊 100% 🔽.

b. **Terrain model has a dimension > 100%:**

- All steps explained above are still possible.
- In addition to this, the white hand right next to the rotation button becomes active as well. After clicking on this so-called view pan button 🔫 ={()=>}, it is also possible to move the model.

---

**Exercise 3.4d: Rotating the model**

After activating the rotation button 🔵 _rotation_axis_, the model can be rotated along the rotation axis, by moving the cursor directly on one of the axis until the cursor changes from 🔵 to 🔬. Otherwise a freehand rotation in any direction is possible.

Figure 3.25: Active project with rotation axes.
Exercise 3.4e: How to switch between 2D and 3D mode

Click \( \square \) to switch from 3D to 2D view. This button then changes to \( \square \) and by clicking again, you will return to 3D view.

Figure 3.26: 3D view of example model.

Figure 3.27: 2D view of example model.

In 2D mode you have all possibilities that work for the 3D mode. It works for input files as well as for simulations. For the following functions of RAMMS it is necessary to switch from 3D to 2D view:

<table>
<thead>
<tr>
<th>INPUT:</th>
<th>OUTPUT:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Draw new polygon shapefile ( \square )</td>
<td>• Draw new polygon shapefile ( \square )</td>
</tr>
<tr>
<td>• Release area information ( \square )</td>
<td>• Draw new line profile ( \square )</td>
</tr>
<tr>
<td>• Draw new domain ( \square )</td>
<td>• Measure distance and angle ( \square )</td>
</tr>
<tr>
<td>• Measure distance and angle ( \square )</td>
<td></td>
</tr>
</tbody>
</table>

3.4.4 Colorbar

As soon as a parameter is shown in the project, the colorbar appears in the panel on the right side of the main window. It can be turned on and off by clicking on \( \square \).

The colorbar can be moved anywhere in the screen (and can get lost). Use Project \( \rightarrow \) Get Colorbar to find a lost colorbar.

Exercise 3.4f: Editing the colorbar

Changing the minimum and maximum values of the colorbar as well as changing the number of colors used is done in the panel AVALANCHE (right of the map window) in the tab Display.
• Simply type a new value into the respective field and hit the return key on the keyboard. The display will then be refreshed.
• To view the underlying topography or image, you can change the transparency.
• **ATTENTION**
  *Values < x.xxx are not displayed!*
  
The cutoff depends on the min and max values as well as on the number of colors. Make sure that you have the range of values you want to display!

• Open the editing window by either choosing *Edit → Colorbar Properties* or clicking [ ] in the vertical toolbar.
• To change the colorbar properties simply click into the field you want to change, then click *OK*.
• Under *Edit → Colorbar White Color* the text-color of the colorbar can be changed to white. This can be useful when changing the background color of your project to white *Track → Preferences → Avalanche Tab → Background Color.*
CHAPTER 4 : RESULTS

3.4.5 How to save input files and program settings

Once a project is created, it is saved under the name and location you entered during step 1 of the RAMMS::AVALANCHE Project Wizard (see Figure 3.11 on page 22). The created input file has the suffix *.av2.

The second situation, in which the input file is saved automatically, is when a calculation is started. The saved input file has the same name as the created output file.

Exercise 3.4g: How to save input files and program settings manually

a. Input file:
   - In case you want to save the input file manually before running a calculation, go on Track → Save. This is helpful when a release area was loaded but you wish to close the project before doing the simulation.
   - If you wish to save a copy of your file under a new name, go to Track → Save Copy As or click .
   - A window pops up to choose an old file which should be overwritten or to type in a new name, then click Save.

b. Program settings
   - If you have moved and/or rotated your project for a better view, you can save this position by going on Extras → Save Active Position.
   - You can now get back to this position anytime by choosing Extras → Reload Position.

Exercise 3.4h: How to open an input file

- Go to Track → Open → Input File, click or use Ctrl+O.
- A window opens to browse for an avalanche input file (*.av2).
- Click Open after the file name was selected.
- The project will be opened.
- Alternatively, you can drag & drop the input file from your windows explorer onto the RAMMS GUI.

Exercise 3.4i: How to visualize a shapefile

- To load a shapefile go to GIS → Add data or click .
- A window opens to browse for a shapefile (*.shp).
- Click Open after the file was selected.
- Alternatively, you can drag & drop the shapefile from your windows explorer onto the RAMMS GUI.
Exercise 3.4j: How to open an output file/avalanche simulation

- Go to Track → Open... → Avalanche Simulation, click or use Ctrl+A.
- A window opens to browse for an avalanche simulation file (*.out.gz)
- Click OK
- The simulation will be opened.
- Alternatively, you can drag & drop the output file from your windows explorer onto the RAMMS GUI.

3.4.6 About RAMMS

Some information about the RAMMS installation on your computer is found here: Help → About RAMMS.

Figure 3.30: About RAMMS
CHAPTER 4 : RESULTS

3.5 Running a simulation

To run a calculation or a specific scenario within a newly created project (creating a project see section 3.3 on page 22) it is necessary to define

- release area(s),
- a calculation domain
- and friction parameters $\mu$ and $\xi$.

The definitions of release area(s) and release heights as well as the set of friction parameters $\mu$ and $\xi$ have a strong impact on the results of RAMMS simulations, the definition of a smaller calculation domain is especially useful to keep the number of calculation points as small as possible. The exercises below show you how to create a release area, a calculation domain and a MuXi-file. Details on the friction model used in RAMMS::AVALANCHE are given in section 3.1.4. on page 15.

3.5.1 Release area(s)

There are different possibilities to include release area(s) into the project. Since Version 1.7.0 it is possible to specify more than one release shapefile. The following table gives an overview of the possibilities RAMMS offers. For further explanations see the exercises below.

<table>
<thead>
<tr>
<th>Create a new release area (polygon shapefile)</th>
<th>If there is no release area available for your project, or you wish to create a new one, switch to 2D mode and click (Draw new polygon shapefile)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open an existing polygon shapefile</td>
<td>Use the file-tree in the right hand panel (Files) and click the shapefile you want to visualize. Or, use the ‘Add data’ button or menu to visualize a shapefile from another source.</td>
</tr>
</tbody>
</table>

The definitions of release areas and release heights have a very strong impact on the results of RAMMS simulations. Therefore we recommend to use reference information such as photography, GPS measurements or field maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area. Release areas can only be drawn in 2D mode.
Exercise 3.5a: How to create a new release area (polygon shapefile)

- Switch to 2D mode by clicking  
- Activate the project by clicking on the map once.
- Click (Draw new polygon shapefile).
- Click into the project where you want to start drawing the outline of the release polygon.
- Continue drawing the release polygon by moving the cursor and clicking the left mouse button.
- To end the release polygon, click the right mouse button. The polygon will be closed automatically.

Figure 3.31: Drawing a new release area.

Before the release area is created, you have to answer a few questions:

- **Add more polygon areas?**
  You can either answer with **Yes** and create a second release polygon as explained above or answer with **No** and continue with the next step.
- **Choose a new polygon shapefile name:**
  Enter a new name for the polygon area.

The polygon area will now be created and opened directly, as well as the colorbar.
Exercise 3.5b: How to visualize an existing release area (polygon shapefile)

Visualize shapefiles by clicking on the filenames in the file-tree (1, right panel), use the ‘Add data’ button (2) or drag & drop shapefile(s) from the Windows file explorer onto the RAMMS topography.

In Figure 3.32 we selected two polygon shapefiles: 3Rel.shp, consisting of three polygons, and 2Rel.shp with two polygons. For every polygon, we can specify a release depth and/or release delay. Not every polygon must contain a release depth, only the ones we want to release, see exercises below.

Once polygon area(s) are created or loaded, you have to specify the release height(s). Switch to 2D mode, choose Input → Release area... → Details/Edit release area, click the button or right-click the polygon shapefile in the Files-Tab and choose Release properties, and choose the release area polygon by selecting it with the left mouse button. The appearing window (Figure 3.33) yields information about release area, mean slope angle, mean altitude and estimated release volume. And, most importantly, the release height can be entered, see exercise below. Do this for every release area you wish to release. You can specify one release area, or multiple release area(s), see exercise below.
Exercise 3.5c: Specify release depth(s) and view release information

- Switch to 2D mode by clicking  
- Activate the project by clicking on the map once.
- Click on the View/Edit release area button (1), choose Input → Release area... → Details/Edit release area or right-click the filename and choose Release properties.
- Then click into the release area you want to get information on (2). A red polygon is drawn around the selected release area. The following window appears:

![Figure 3.33: View/Edit release area](image)

- Enter a release depth in the field Release depth d0 (m). The corresponding release volume is updated automatically.
- Additionally the following release area parameter are shown: mean slope angle, mean altitude, projected area and inclined (real) area.
- A release delay in (s) can be specified in the last line, see next Figure.

Remark: The estimated release volume is very accurate for the grid resolution of your input project. If you calculate a different simulation resolution, the estimation can differ from the calculated release volume.

In Figure 3.33 we selected the northern-most polygon of the shapefile 3Rel.shp and assigned a release depth of 0.5m.
Let’s assign a release delay (secondary avalanche release) for one of the polygons in 3Rel.shp.

Therefore, we again click on (1) and choose the middle polygon of 3Rel.shp (2), see Figure 3.34 below. We then specify a release depth of 0.3m and a delay of 10s (3).

![Figure 3.34: About](image)

We do not specify a release depth for the last polygon of 3Rel.shp.
In a next step we can specify a release height for one of the two polygons of shapefile 2Rel.shp, see below.

Additional release information is found in the Avalanche panel, tab Volumes, see Figure 3.36 above.
3.5.2 Calculation Domain

To reduce calculation time, you can specify a smaller calculation domain to reduce the number of computational cells. By analyzing a calculation with a coarse grid (large cell size), e.g. with a cell size of 5 or 10 m, you get an idea where the flow path is situated and you can limit the calculation domain to the area of interest.

Switch to 2D mode and choose Input → Calculation Domain... → Draw New Domain or click 🍰. Now you can draw a polygon containing the area of interest similar to drawing a new release area (see section “Release area(s)” on page 35). We strongly recommend using smaller calculation domains especially if you calculate with small cell sizes (e.g. < 5m).

Figure 3.37: Calculation domain in green encloses the area of interest and reduces calculation time in comparison with the default rectangular domain which is automatically generated.
Exercise 3.5d: Finding an optimized calculation domain

- Open your input file.
- Draw a rough calculation domain as explained above, see Figure 3.38 below.

![Figure 3.38: Input file with big calculation domain](image)

- Do a rough calculation with a simulation resolution of 10m. Use constant $\mu$ and $\zeta$ values of e.g. $\mu=0.2$ and $\zeta=2000$.
- Wait for the simulation to finish. The simulation result will be displayed.
- Click the Max Flow Height button.

![Figure 3.39: Max Flow Height of a 10m simulation with constant mu and xi](image)

- Click GIS → Export… → Create Envelope Shapefile
- A question pops up: Use buffer?
- Click Yes. We want to use the envelope shapefile as a calculation domain, and therefore we want to buffer it a little bit (click No if you want to have the exact envelope).
• Choose a filename for the envelope shapefile (a name is proposed).
• The created envelope shapefile is shown in the visualization as a dashed red line.

![Figure 3.40: Envelope shapefile of Max Flow Height extent](image)

• Switch back to the input file
• Use Input → Calculation Domain... → Load Existing Domain to load your envelope shapefile as a new calculation domain, see Figure 3.41 below.

![Figure 3.41: Input file with optimized calculation domain (envelope shapefile)](image)

• Now redo your simulation with a simulation resolution of 5m and a MuXi-file.
3.5.3 Friction parameters $\mu$ and $\xi$

Forest area

It is sometimes necessary to take forest areas into account, when running a simulation with variable friction parameters ($\mu$ and $\xi$). Beware: If your scenario is an extreme scenario, then it might not be appropriate to use forest information, as a forest would be completely destroyed by an extreme avalanche.

There are different ways to consider forest information:

(1) Import a digital forest file (ASCII grid or forest shapefile): Use **Input $\rightarrow$ Forest... $\rightarrow$ Import Forest from SHAPEFILE** or **Input $\rightarrow$ Forest... $\rightarrow$ Import Forest from ASCII Grid**.

(2) draw a forest file manually: See exercise below.

---

**Exercise 3.5d: How to create a FOREST file**

- Switch to 2D mode by clicking $\rightarrow$.
- Activate the project by clicking on the map once.
- Click $\rightarrow$ or choose **Input $\rightarrow$ Polygon Shapefile... $\rightarrow$ Draw New Polygon Shapefile**.
- Trace the forest outline by creating as many FOREST area polygons as necessary (proceed as in section “Release area(s)” on page 35) and name your new forest shapefile accordingly. The shapefile will be shown as a red dashed line in the GUI.
• Then right-click the shapefile in the Files-tree and choose *Import forest from shapefile*, see below.

![Figure 3.43: Import forest from shapefile](image)

• You are asked, if you want to import the created FOREST file into your project. Click **yes**, if you want to use the newly created FOREST (ignore the next point in this case). Otherwise click **no** and import the FOREST file later, as explained in the next point.

• Import the new FOREST shapefile: Choose **Input → Forest... → Import Forest Area from SHAPEFILE**, then select your FOREST shapefile.

• This new FOREST information is not automatically taken over in existing MuXi-files. Therefore, recreate existing MuXi-files if needed. If you create a new MuXi-file with **Input → Friction Values... → Create new MuXi File (Automatic Procedure)**, the forest will now be considered.
CHAPTER 4 : RESULTS

Global parameters

The friction parameters $\mu$ and $\xi$ strongly depend on the volume and the return period of the avalanche. So prior to creating a new MuXi-file click Input $\rightarrow$ Global parameters and choose the return period and the volume category of the avalanche you would like to simulate. The MuXi-file will be calculated based on these values. Changing the return period and/or volume category has no effect on already existing MuXi-files. The default volume category is chosen based on the specified release volume.

Figure 3.44: RAMMS global parameters
MuXi-file

In RAMMS::AVALANCHE you can automatically generate a $\mu$ and $\xi$ file based on topographic data analysis, forest information and global parameters. The following exercise shows how to create and load MuXi-files for a RAMMS simulation with variable friction parameters.

**Exercise 3.5e: How to create a new MuXi-file**

- Choose `Input → Friction Values... → Create new MuXi File (Automatic Procedure)` or click `µ`.
- A window pops up where you have to define an appropriate return period and check your avalanche volume. You can also define these global parameters under (`Input → Global Parameters`).
- Enter a file name (e.g. Test).
- Unless you know better, leave the values as they are.
- Click `ok`.
- If this is the first MuXi-file for this project, or if you changed or removed a forest cover or if you changed the altitude limits when entering the file name, RAMMS will start a terrain classification. Otherwise, RAMMS will skip the terrain classification (the classification is saved in the file `muxi_class.asc` in the logfiles folder).
- The MuXi-file will be visualized after its creation. The $\mu$- and $\xi$-values are saved in two asc-files (`Test_mu.asc` and `Test_xi.asc` respectively). Only the region within the calculation domain will be visualized.
- You can switch between the release area (if already loaded), and the $\mu$ and $\xi$ values in the choose Visualization area in the avalanche panel.

**Exercise 3.5f: How to load an existing MuXi-file**

- Choose `Input → Friction Values... → Load existing MuXi File`
- A window opens to browse for an existing MuXi-file.
- Click `open` and the file will be loaded.
3.5.4 How to run a calculation

To run a calculation you have to open a created project (section 3.3), load a release area (section 3.5.1), and a calculation domain (section 3.5.2). A MuXi-file is necessary as well. Below you find two examples, one for running a constant calculation (constant release height and constant friction parameters $\mu$ and $\xi$) and one for using variable friction parameters.

Exercise 3.5g: How to run an avalanche calculation

- To run a simulation choose Run $\rightarrow$ Run Avalanche Calculation or click $\text{Run Simulation}$.
- The RAMMS $\mid$ Run Simulation window opens. Before clicking Run Simulation, you should check the input parameters.

General Tab:

- OUTPUT Name
  (1) Output filename: Choose a good output filename, add parameter information to the filename to recognize the output file.

- Additional Information
  (2) Project name.
  (3) Project info: Add valuable project information to this field.
  (4) File Info: Calculation domain file and digital elevation model (DEM).

- Stop Parameter
  (5) The stopping criteria in RAMMS is based on the momentum, see section.

- Remarks
  (6) “Escape” and “Ctrl+R” can be used to cancel resp. start a simulation.
  (7) Check box Run in background: Option to run simulations in background mode. The RAMMS interface remains active and allows the user to start e.g. new simulations.

Figure 3.45 General Information
Continuation of exercise 3.5g: How to run a constant avalanche calculation

**Params Tab**

- **Simulation Parameters**
  1. Grid resolution: Change, if necessary. The resolution should always be chosen so that important features of the terrain are represented in the terrain model. High resolution grids will extend your calculation time.
  2. End time: Choose simulation end time.
  3. Dump-step: The dump-step interval defines the resolution of the animation of your simulation but has no effect on the simulation results.
  4. Density: Keep the default value for density if no further information on the avalanche density is available (300 kg/m³).

- **Numerical Parameters**
  5. Numerical Scheme: Change numerical solver, 1st or 2nd order scheme. We recommend using 2nd order, because it provides more accurate solutions of the equations than 1st order. However, if you encounter stability problems it may be useful to run your calculation using the 1st order numerical scheme.
  6. Keep the default value for the Null-height H cutoff (0.000001m). Unrealistic shallow flow heights of the simulation are eliminated to minimize numerical errors.

- **Miscellaneous Parameters**
  7. Obstacle/Dam File: Draw polygons of areas, where no avalanche should pass (houses, deflecting dams, obstacles). The flow is deflected.
  8. Curvature: Switch Curvature on or off.

![Parameter Tab](image-url)
Continuation of exercise 3.5g: How to run a constant avalanche calculation

Mu/Xi FRICTION PARAMETERS

1. **Constant**: For a calculation with constant MuXi-values, click **Constant**. Enter \( \mu \) and \( \xi \) values below. Choose Help → RAMMS Manuals... → friction Parameter Table (PDF) or see friction value table on page 89 for an idea of \( \mu \) and \( \xi \).

2. **Variable**: For a calculation with variable MuXi-values, click **Variable**. You should have created a MuXi-file before starting a variable MuXi calculation.

3. **Define additional MuXi areas**: You can specify up to two additional polygon areas where you can change the MuXi-values. **But beware**: You have to be able to justify these changes!

RELEASE PARAMETERS

1. **Filename**: List of all the release shapefiles in use.
2. **Volume (\( m^3 \))**: The estimated release volume per shapefile is indicated in the second row.
3. **Depth (m)**: Release depth per shapefile.
4. **Delay (s)**: Release delay per shapefile. In this example, the shapefile “secondrel.shp” has a start delay of 30s.
5. **Total Volume (m\(^3\))**: Sum of all the release volumes from above.
6. **Run Simulation Button**
Continuation of exercise 3.5g: How to run an avalanche calculation

Run Simulation
- Click run simulation (Figure 3.48)
- If you want to start several simulations automatically (e.g. over night) use Track → New... → Run Batch Simulations. You can choose how many computational cores the Batch-Mode should use.
- The following window appears, showing the status of the calculation (Figure 3.49)
  General information of the simulation (1), output filename (2), starting the calculation (3), for every dump step RAMMS outputs max flow height (Hmax) and velocity (Vmax) (4), moving momentum (%) (5) as well as flow volume, outflow volume (if it exists) and numerical volume loss.

Figure 3.49: Calculation status window.

Figure 3.50: Background simulation mode window.
Press any button to close the DOS window.
4 Results

Once the simulation is finished, the simulation as well as the output logfile (see Figure 4.3) are opened in RAMMS. (If you ran the simulation in background mode, see Figure 3.50, click any button inside the DOS window to close the window. Afterwards, open the simulation in RAMMS manually).

If mass flows out of the calculation domain, RAMMS shows an alert (Figure 4.2). To get reliable results you should enlarge your calculation domain (see section 3.5.2).
CHAPTER 4 : RESULTS

4.1 Project information

Once a scenario within a specific project is calculated it is possible to open the *output logfile* (in output mode) including project settings and information as well as calculation specifications. You can open the project’s output log with *Project → Output Log File*. A window as shown in Figure 4.3 opens. This window provides information about your project and is the first thing to look at after running a simulation to check your simulation results.

1. Information on simulation time and resolution. Be sure the simulation stopped due to *LOW FLUX*. Otherwise the output *TIME END CONDITION* informs you, that your simulation stopped before the avalanche reached the stopping criteria you defined for the simulation (see section 4.2.5 on page 63).

2. Information on simulation results.

3. Input logfile (see Figure 4.4).

![Figure 4.3: Output Logfile.](image)
CHAPTER 4 : RESULTS

The *input logfile* (included in the output logfile), however, can already be opened once a project is created and before a simulation is performed.

There are two ways to view your project settings and information. First you can open your project’s input logfile (or output logfile, in *output mode*), or you can check your project’s region extent and area in the avalanche panel (region tab).

You can open the project’s input log file with *Project → Input Log File*. The following window opens:

This window provides information about all your project’s input specifications, like number of nodes and cells, release areas, which DEM was used, the loaded map and orthophotos as well as your global simulation parameters.

![Figure 4.4: RAMMS Project Input Log file.](image)

To view the project coordinates, click the region tab in your avalanche panel. The region tab lists X- and Y-Coordinates of the lower left (minimal values) and upper right (maximal values) corner (these are coordinates you entered when creating the project) as well as the global minimum and maximum altitude (Z value). Additionally, the total region area is shown (in km²).

![Figure 4.5: Region extent (X-, Y- and Z-coordinates, total projected area).](image)
CHAPTER 4: RESULTS

4.2 Visualization and analysis of the results

This section gives a short overview on what is possible in RAMMS to view and analyze the simulation results. The interpretation of the results has to be done by an expert who is familiar with the local as well as with the topographic and meteorological situation of the investigation area.

RAMMS is a model and each model is a simplification of reality, therefore the simulation results should not be analyzed without questioning them. We strongly recommend that all users perform sensitivity studies.

4.2.1 Visualize different parameters

The drop down menu Results offers the following functions:

- Flow Height
- Flow Velocity
- Flow Pressure
- Flow Momentum
- Max values (Height, Velocity, Pressure, Momentum, Shear Stress)
- DEM Adoptions (Add Deposition to DEM)
- Flow Analysis (Summary of Moving Mass)
- Friction Values (μ, ξ)
- Cell area (m²)

These results are all visualized by a color-plot in the topography. See exercise “4.2a Displaying calculation values” below.
Exercise 4.2a: Displaying calculation values

The maximum values of flow height, velocity and pressure give a good overview of the dimension of the avalanche. You find them under Results → Max values…

→ Max flow height
→ Max velocity
→ Max pressure

Figure 4.6: Results: Maximum values of flow height (left), velocity (middle) and pressure (right)

The flow height can be visualized exaggerated by a factor. Click Help → Advanced… → Additional Preferences… → Edit to change the factor of the quasi 3D-visualization of the flow height under the keyword exaggeration.

Figure 4.7: Quasi 3D-Visualization of flow height (left: exaggeration 1; right: exaggeration 5).
4.2.2 Line profile and time plot

In the horizontal toolbar you find two further functions:

- Line Profile
- Time Plot

**Line profile**

A line profile is a good alternative to the color plot if the avalanche snow height, velocity or pressure should be known at a specific location. The graph shows the currently active parameter. Every line profile is saved in the file `profile.shp` in the project directory. If you want to keep this line profile, you have to save it, see exercise “4.2b How to draw a line profile” below.

**Time plot**

This function provides a time plot at a single point. This is helpful when it is of interest to know the values and maximum values at a specific location (e.g. at a building, dam, or a tree) through time. Every point is saved in the file `point.shp` and a point-info file `point_info.txt` is additionally saved in the project directory. If you want to keep this point, you have to save it, see exercise “4.2c How to create a time plot” below. The point-info file can be visualized with **Extras → Point… → View Point Info File.**
Exercise 4.2b: How to draw a line profile

a) Draw a new line profile:

- Switch to 2D mode by clicking
- Activate the project by clicking on it once, then click or choose Extras → Profile → Draw New Line Profile
- Define the line profile in the same way you specify a new release area. Finish the line profile with a right-click on the mouse button.
- A window opens, displaying the line profile.

![Figure 4.8: Line profile plot.](image)

- Filled grey area active parameter (scale on left side).
- Red line active parameter (multiplied by 50) added to the track profile (altitude, scale on the right side).
- Black line track profile (altitude, scale on the right side).
- Bottom scale projected profile distance (in m).

- If you change the active parameter, min or max values or the dump-step in RAMMS, the plot is directly updated. You can also start the simulation and then watch the time variations in your line profile plot.
- It makes sense to either draw a profile line perpendicular to the flow direction or draw the line along the flow path. Basically every imaginable path is possible.
Continuation of exercise 4.2b: How to draw a line profile

Figure 4.9: Line profile perpendicular to flow direction.

Figure 4.10: Line profile along the flow direction.

- To save the coordinates of the points belonging to the line profile, go on *Extras → Profile → Save Line Profile Points* and enter a file name.
- To save the line profile parameters (distance in m and the active parameter, e.g. the flow height in m) at the current dump-step, go on *Extras → Profile → Export Profile Plot Data* and enter a file name.
CHAPTER 4 : RESULTS

Continuation of exercise 4.2b: How to draw a line profile

b) Load an existing line profile:
   - Switch to 2D view by clicking 
   - Activate the project by clicking on it once and click or choose Extras → Profile → Draw New Line Profile
   - Click the middle mouse button once
   - A window pops up and you can browse for the line profile you wish to open

Exercise 4.2c: How to create a time plot

a) Select time plot point:
   - Click or choose Extras → Point → Choose Point
   - Click into the map at the point where you want to create a time plot.
   - A window opens, displaying the time plot at the point of interest (active parameter vs. time).

   ![Time plot window](image)

   Figure 4.11: Time plot window.

   - To save the point coordinates, choose Extras → Point → Save point Location and enter a file name
   - To save the time plot data (time in s and the active parameter, e.g. the flow height, for every dump-step), choose Extras → Point → Export Point Plot Data and enter a file name.
Continuation of exercise 4.2c: How to create a time plot

b) Load a time plot:
   - To reopen the time plot graph window of the last selected point, go on **Extras → Point → Create Point Time Plot**
   - To open an arbitrary time plot that was saved any time before, click ...
   - Click the **middle mouse button** once.
   - A window pops up and you can browse for the time plot file you wish to open.

c) Enter point coordinates and get a time plot:
   - Go to **Extras → Point → Enter Point Coordinates (X/Y)**
   - Enter X-coordinates of your point of interest. Click **OK**.
   - Enter Y-coordinates of your point of interest. Click **OK**.
   - The time plot opens.

4.2.3 Deposition analysis

A deposition analysis (flow height) for a region of interest (ROI) can be done in the following way:

   - right-click the shapefile you want to analyse
   - choose **Deposition analysis**

Figure 4.12: Deposition analysis of region of interest.
4.2.4 Creating an image or a GIF animation

Image
It is possible to export your results as an image in different formats (e.g. .png, .jpg, .gif, .tif etc.). Click or choose Track → Export… → Image File and define a file name with the corresponding extension. An image of the visible part in the viewer will then be exported.

GIF animation
Creating a GIF animation is only possible in output mode. Click or choose Track → Export… → GIF Animation. Enter a file name and location and wait until the simulation stopped. As soon as the simulation finished, the GIF animation file is saved. In the Preferences in the avalanche tab you can define the interval for the GIF animation (GIF animation interval [s]).
4.2.5 Stopping mechanism

Check the output logfile under Project → Output Logfile to verify your simulation stopped due to low flux (see Output Logfile on page 53). Otherwise enlarge the end time of your simulation (see exercise “Run a calculation” on page 47). To check the stopping of your simulation click Results → Summary of Moving Mass. A window similar to Fig. 4.12 opens which shows the summary of moving mass. For every dump-step, RAMMS summed up the momenta of all grid cells, and compared it with the maximum momentum sum. If this percentage is smaller than a user defined threshold value (see page 50), RAMMS aborts the simulation and the avalanche is regarded as stopped.

The stopping criteria in RAMMS is based on the momentum. In classical mechanics, momentum \( p \) (SI unit kgm/s, or, equivalently, Ns) is the product of the mass and velocity of an object \( p = mv \). Threshold values between 1-10% are reasonable, but this is only a suggestion and has to be empirically determined for each test case.

Stopping criteria with large threshold values (e.g. >10%) may result in unrealistic early stopping of a simulation.

Small threshold values however may lead to numerical diffusion of the simulation results and very slow creeping of the avalanche material and velocity oscillations.

Figure 4.14: Summary of moving mass.
Whether or not an avalanche stops depends on terrain (slope angle in runout), total flow volume and friction values and should always be evaluated by an expert. In case of doubt on how to choose threshold values we recommend running a simulation with a 1% threshold and checking the summary of moving mass for numerical diffusion and analyzing the avalanche runout (flow height and flow velocity) with time plots (section 4.2.2).

Figure 4.15: Stopping behaviour of a RAMMS simulation. Small threshold values may lead to unlikely slow creeping of the material. In the example shown in the figure above the stopping criteria is set to 0%.

Figure 4.16: Stopping behaviour of a RAMMS simulation. In this example threshold values <2% lead to numerical diffusion of the simulation results. A threshold values between 3-5% seem to be appropriate in this case.
4.3 Adding structures or deposition to DEM

The option to adding structures or deposition to DEM must be used with great care and should not be used to design deflecting dams. Deflecting or catching dams can neither be designed directly with RAMMS nor can the residual risk below dams be calculated directly with RAMMS. RAMMS takes important factors in dam design such as energy dissipation, dam geometry or snow deposits in front of a dam not properly into account. Dams have to be designed using well known standard engineering procedures, e.g. Johannesson et al. 2009 [1], Rudolf-Miklau and Sauermoser 2011 [2]. RAMMS is well suited to calculate the key input factors for dam design such as flow height and velocity. The dam option should however only be used to try to visualize the influence of guiding or small deflection of the avalanche mass. RAMMS cannot be used directly to evaluate if the height of a deflecting dam is sufficient for a certain scenario or not (see explanations below).

4.3.1 Creating a dam

RAMS offers the possibility to simulate the presence of a deflecting dam by increasing the altitude at the position where a dam is considered. This option helps the user to design mitigation structures and to test its influence on potential flow paths near populated areas.

<table>
<thead>
<tr>
<th>Exercise 4.3a: How to create a new DEM to simulate a dam</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Create a polygon shapefile where a dam is supposed to be built (Figure 4.17).</td>
</tr>
<tr>
<td>• Create a second, inner polygon, if you wish to have a two-stage dam.</td>
</tr>
<tr>
<td>• Go on GIS → Add DAM to DEM…</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>• You will be asked to “Open dam file (*.shp)”. Select the shapefile you want to use as the outer edge of the dam.</td>
</tr>
<tr>
<td>• The question pops up, if you want to “Open 2nd dam shapefile (inner polygon)?”</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>• Next step is to enter the total elevation height or the total relative height of the dam in meters. This is the elevation of the dam crest.</td>
</tr>
<tr>
<td>• If you loaded an outer polygon file, you will be asked to enter the intermediate height (m) (height of the outer polygon file) as well.</td>
</tr>
<tr>
<td>• Finally you have to “Enter new XYZ name”. Your new xyz-file with the topographic information, containing the “dam”, is created in your project directory.</td>
</tr>
</tbody>
</table>
To run a simulation based on the new created xyz-file, all you have to do is to choose the new xyz-file in the Run Simulation window, see below:

Figure 4.19: Select new xyz-file with dam information.
While RAMMS is able to simulate the effect of a dam lying lateral to the direction of flow quite well, there might occur numerical problems if a dam lies perpendicular to the direction of flow.

- Because there is no energy dissipation due to collision with dams implemented in RAMMS, unrealistically large flow velocities and flow heights may be simulated in front of a dam.
- The numerical solver used in RAMMS incorporates information from neighboring cells. The effect of dams with only one cell as dam side wall may therefore be difficult to simulate.

If you encounter problems with the simulation of mitigation measures as described, we suggest creating a DEM including a dam in GIS, ideally using progressively increasing side walls as shown in Figure 4.21.

The interpretation of RAMMS simulations including mitigation measures such as dams has to be done by experts. In addition we recommend to always check the simulation results with engineering approaches.
CHAPTER 4 : RESULTS

4.3.2 Creating a new DEM with avalanche deposition

In case you wish to simulate an avalanche overflowing a previous avalanche, you should take into account the deposition of the previous avalanche, because the path of the second avalanche will be influenced by the modified terrain. In RAMMS one has to assume that the deposits from an initial avalanche are not entrained by a subsequent avalanche. To do this, in the output mode, users can select the option Add Deposition to DEM to add the flow height of an avalanche to the DEM at any arbitrary dump-step. A new xyz-file (with the updated topographic information) will be created.

Exercise 4.3b: How to add avalanche deposition to new DEM

- The deposition height is the flow depth at the end of a simulation when the avalanche is considered to have stopped moving (alternatively, earlier dump-steps may be used if there are reasons to believe the flow should have stopped earlier). So first view the results at the last time step or a different time step, if desired.
- Go to Results ➔ Add Deposition to DEM
- Enter a new name for the new xyz-file.
- The new xyz-file, containing the deposition information, is created. To run a simulation based on this new xyz-file, just choose the xyz-file in the Run Simulation window, see Figure 4.19.
CHAPTER 5 : PROGRAM OVERVIEW

5 Program overview

RAMMS is a windows-based program that relies on drop-down menus and dialog boxes to set the model parameters, run calculations and view results. Toolbar buttons are also available and provide short-cuts of the menu path; moving the cursor over a button results in a short explanation, appearing in a text box below the cursor (‘tooltip’). For functions not available in the current context, the menus and buttons are deactivated and cannot be used.

5.1 The Graphical User Interface (GUI)

The graphical user interface (GUI) (Fig. 5.1) consists of menu bar, horizontal and vertical toolbar, main window, time step slider, right and left status bar, colorbar and panel. They will be explained in the following sections.

![Figure 5.1: Graphical user interface (GUI)]
CHAPTER 5 : PROGRAM OVERVIEW

5.1.1 The menu bar

Track

Similar to the Microsoft Windows File menu, Track is used to open, close, save, print, backup and export files.

| New... | • Project Wizard | Start a new project, guided by the wizard (Ctrl + w) |
|        | • Convert XYZ → ASCII grid | Convert regular XYZ data (e.g. laser scanning data) into an ESRI ASCII grid. |
|        | • Run BATCH simulations | Possibility to start simulations automatically (e.g. overnight) You can choose how many computational cores the Batch-Mode should use (quasi parallel simulations, saves computational time). |
|        | • Export ASCII Files from Simulations (Batch) | Automatically export all ASCII files (max height, max velocity, max pressure, deposition) from multiple output files. |
| Open... | • Input File | Open an existing input file (*.av2) (Ctrl + O) |
|         | • Avalanche Simulation | Open an existing avalanche simulation (*.out.gz) (Ctrl + A). |
| Close | | Close active file (input or output) |
| Save | | Save active file (Ctrl + S) |
| Save Copy As | | Save a copy of the active file (e.g. test.av2) under a new name (e.g. simulation1.av2, works only in input mode). |
| Export... | • Image File | Create an image of the active window in a chosen format. You can choose the desired image format using the file extension (e.g. .png, .jpg, .gif, .tif, etc.). |
|          | • GIF Animation | Create a GIF animation (only in output mode). Change GIF animation interval (s) and delay (s) in the preferences. |
| Backup... | • Backup RAMMS Version | Make a backup of the current RAMMS Version. |
|           | • Backup Active Project | Backup your active project. The user will be asked if he wants to include output files in the backup. This function is useful when having problems with a simulation. Make a backup and send the zip-file together with some explanations to ramms@slf.ch. Make sure that all your input data (release area shapefiles, domain files, etc…) is in the project folder. |
|           | • Backup User Defined Files/Folders | Backup any folder or files you want. |
| Preferences | | Change RAMMS preferences (Ctrl + P) |
| Log files... | • RAMMS Logfile (current) | Show active RAMMS logfile. |
|             | • RAMMS Logfile (last session) | If RAMMS crashed, open this logfile and copy/paste the content into an email to ramms@slf.ch. |
### CHAPTER 5 : PROGRAM OVERVIEW

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restart RAMMS</strong></td>
<td>Restart RAMMS</td>
</tr>
<tr>
<td><strong>Exit</strong></td>
<td>Exit RAMMS (Ctrl + Q).</td>
</tr>
</tbody>
</table>

**Edit**

This menu is used to edit colorbar, axes and dataspace properties.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Colorbar Properties</strong></td>
<td>Edit the colorbar properties.</td>
</tr>
<tr>
<td><strong>Get Colorbar</strong></td>
<td>Get back your colorbar, if lost.</td>
</tr>
<tr>
<td><strong>Dataspace Properties</strong></td>
<td>Edit your dataspace properties.</td>
</tr>
<tr>
<td><strong>Show Dataspace Axes</strong></td>
<td>Shows or hides dataspace axes of the project region. The axes are only visible if the background color is NOT set to black.</td>
</tr>
<tr>
<td><strong>Colorbar White Color</strong></td>
<td>Checkbox. If checked, the colorbar text-color is white (default), otherwise black.</td>
</tr>
</tbody>
</table>
### CHAPTER 5 : PROGRAM OVERVIEW

#### Input

Menu used to specify global parameters, calculation domain, release area, friction parameters and forest cover. This menu is active only in input mode.

<table>
<thead>
<tr>
<th>Global Parameters</th>
<th>Set return period and avalanche volume. These parameters are used to calculate a friction MuXi-File.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation Domain...</td>
<td></td>
</tr>
<tr>
<td>• Draw New Domain</td>
<td>Draw a new calculation domain. The mouse cursor changes to an arrow. Select points with the left mouse button, finish with a right mouse button click (the final right mouse button click is NOT a point of your calculation domain). This works only in 2D mode.</td>
</tr>
<tr>
<td>• Load Existing Domain</td>
<td>Load an existing calculation domain (*.shp). Any polygon shapefile can be used as calculation domain.</td>
</tr>
<tr>
<td>Polygon Shapefile...</td>
<td></td>
</tr>
<tr>
<td>• Draw New Polygon Shapefile</td>
<td>This activates the button to draw new polygon shapefiles. The mouse cursor changes to an arrow. Select points with the left mouse button, finish with a right mouse button click (the final right mouse button click is NOT a point of your polygon). This works only in 2D mode.</td>
</tr>
<tr>
<td>• Load Existing Polygon Shapefile</td>
<td>Load an existing polygon shapefile.</td>
</tr>
<tr>
<td>Release Area...</td>
<td></td>
</tr>
<tr>
<td>• Details/Edit Release Areas</td>
<td>The mouse cursor changes to an arrow and you can select a release area to define the release depth and to view release area information. This works only in 2D mode.</td>
</tr>
<tr>
<td>Forest...</td>
<td></td>
</tr>
<tr>
<td>• Show Active Forest Cover</td>
<td>If forest cover is taken into account, the corresponding shapefile is displayed. If your project uses no forest cover at the moment, RAMMS will tell you so.</td>
</tr>
<tr>
<td>• Import Forest Area From SHAPEFIL</td>
<td>You can import any polygon shapefile using this function.</td>
</tr>
<tr>
<td>• Import Forest Area From ASCII grid</td>
<td>If a forest ASCII grid is available, it can be imported using this function (0 = no forest, 1 = forest).</td>
</tr>
<tr>
<td>• Remove Active Forest Cover</td>
<td>Remove the active forest raster data from the project.</td>
</tr>
<tr>
<td>Friction Values...</td>
<td></td>
</tr>
<tr>
<td>• Load an Existing MuXi File</td>
<td>Load afore created MuXi-file (*.mu.asc or *.xi.asc).</td>
</tr>
<tr>
<td>• Create New MuXi File (Automatic Procedure)</td>
<td>The DEM is analyzed, classified and according to altitude, slope and curvature information, return period and avalanche volume, a new MuXi-file is created.</td>
</tr>
<tr>
<td>• Show MuXi Classification</td>
<td>Shows the result of the MuXi-classification.</td>
</tr>
</tbody>
</table>
CHAPTER 5 : PROGRAM OVERVIEW

Show

This menu enables and disables the different visualizations. A little arrow indicates if the visualization is enabled or disabled.

<table>
<thead>
<tr>
<th>Show Lights</th>
<th>Show/hide light effects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Grid</td>
<td>Show/hide computational grid</td>
</tr>
<tr>
<td>Show Map</td>
<td>Show map</td>
</tr>
<tr>
<td>Show Image</td>
<td>Show orthophoto/image</td>
</tr>
<tr>
<td>Show Visualization</td>
<td>Show/hide release area (input mode) or simulation results (output mode)</td>
</tr>
<tr>
<td>Show Arrow</td>
<td>OUTPUT</td>
</tr>
<tr>
<td>Show Colorbar</td>
<td>Show/hide colorbar</td>
</tr>
<tr>
<td>Show Bottom Color</td>
<td>Show/hide 0-color</td>
</tr>
<tr>
<td>Show Velocity Arrow</td>
<td>OUTPUT</td>
</tr>
<tr>
<td>Show Domain</td>
<td>INPUT</td>
</tr>
</tbody>
</table>

Run

This menu is active only in input mode.

<table>
<thead>
<tr>
<th>Run Calculation</th>
<th>Opens the Run Simulation window to change parameters and to start the calculation of an avalanche simulation (F8).</th>
</tr>
</thead>
</table>
CHAPTER 5 : PROGRAM OVERVIEW

Results

This menu contains the results functions and is only active in output mode.

<table>
<thead>
<tr>
<th>Flow Height</th>
<th>Shows flow height of the avalanche every time step.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Velocity</td>
<td>Shows flow velocity of the avalanche for every time step.</td>
</tr>
<tr>
<td>Flow Pressure</td>
<td>Shows flow pressure of the avalanche for every time step.</td>
</tr>
<tr>
<td>Flow Momentum</td>
<td>Shows flow momentum of the avalanche for every time step.</td>
</tr>
<tr>
<td>Max Values...</td>
<td></td>
</tr>
</tbody>
</table>
  • Max Flow Height | Displays the maximum flow height for each cell. |
  • Max Velocity | Displays the maximum velocity for each cell. |
  • Max Pressure | Displays the maximum pressure for each cell. |
  • Max Flow Momentum | Displays the maximum momentum for each cell. |
  • Max Shear Stress | Displays the maximum shear stress for each cell. |
| Add Deposition to DEM | Adds the deposition of an avalanche simulation to a new DEM. |
| Summary of Moving Mass | Summarizes the Moving Mass. |
| Mu | Displays the friction parameter \( \mu \) for this simulation. |
| Xi | Displays the friction parameter \( \xi \) for this simulation. |
| Grid Cell Area | Display the grid cell area for each cell \( (m^3) \). |
CHAPTER 5 : PROGRAM OVERVIEW

GIS

This menu contains miscellaneous GIS functions.

<table>
<thead>
<tr>
<th>Add Data</th>
<th>Add data (shapefiles, MuXi-ASCII files) to the visualization.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export ...</td>
<td></td>
</tr>
<tr>
<td>• Results As Shapefile</td>
<td>Export the active result to an ESRI GIS shapefile for later use in a GIS program.</td>
</tr>
<tr>
<td>• Results As ASCII Grid</td>
<td>Displays the maximum velocity for each cell.</td>
</tr>
<tr>
<td>• Envelope Shapefile</td>
<td>Create an envelope shapefile from the active result.</td>
</tr>
<tr>
<td>• Envelope Shapefile from ASCII File</td>
<td>Create an envelope shapefile from an ASCII file. User can specify an ASCII file (e.g. max flow height).</td>
</tr>
<tr>
<td>Add Dam to DEM</td>
<td>Adds a dam to the DEM. You have to specify relative dam height or absolute dam elevation.</td>
</tr>
<tr>
<td>Show Slope Angle (*)</td>
<td>Display the slope angles.</td>
</tr>
<tr>
<td>Show Curvature (1/m)</td>
<td>Display the curvatures.</td>
</tr>
<tr>
<td>Show Contour Plot</td>
<td>Display a contour plot.</td>
</tr>
<tr>
<td>Resample Slope/Curvature</td>
<td>Resamples slope/curvature plots to a user defined resolution.</td>
</tr>
</tbody>
</table>
### Extras

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add/Change or Remove map</strong></td>
<td>Add or change the topographic map of your project. The maps can be located in your project directory, or in your distribution’s ‘Map’ folder, see section 3.2 for details. If not, you can browse for the maps.</td>
</tr>
<tr>
<td><strong>Add/Change or Remove Image</strong></td>
<td>Add, change or remove the image used for visualization of your project. The images can be located in your project directory, or in your distribution’s ‘IMAGE’ folder, see section 3.2 for details. If not, you can browse for images.</td>
</tr>
</tbody>
</table>
| **Point ...**                        | • Choose Interactively: This activates the button to select a point. The mouse cursor changes to an arrow. Select the point with the left mouse button. This works only in 2D mode.  
• Enter Coordinates (X/Y): Enter the coordinates of a point you are interested in.  
• Create Time Plot: Create a time plot of a selected point.  
• View Info File: View point info file.  
• Save Point Location: Save point location as a point shapefile.  
• Export Time Plot Data: Export time plot data as a txt-file. |
| **Profile ...**                      | • Draw New Line Profile: This activates the button to draw a line profile. The mouse cursor changes to an arrow. Select the points of the line profile with the left mouse button, finish with a right mouse click. This works only in 2D mode.  
• Save Line Profile Points: Save your line profile as a polyline shapefile.  
• Export Line Profile Plot Data: Export the line profile plot data as a txt-file. |
| **Save Active Position**             | Save your current state of view, as well as the enabled and disabled visualizations. |
| **Reload Position**                  | Reload your saved position.                                                                    |
| **Google Earth ...**                | • Export Result to Google Earth: This function exports release areas and your results to Google Earth. If your project location is within Switzerland (default), you can use this function without changing any options. If not, see Map Options.  
• Map Options: Enter map options if you want to export your result from a location outside of Switzerland  
• Map Options Help: Get help about Google Earth Map Options. |
| **View Input File**                  | Opens the input file in a window.                                                               |
| **View Simulation Standard Output Log** | Opens the simulations standard output log in a window (the black DOS window you see when a simulation is running). |
CHAPTER 5 : PROGRAM OVERVIEW

Project

This menu contains the project input and output logfiles.

| Input Log File | Displays the input logfile. |
| Output Log File | Displays the output logfile. The input logfile is appended to the output logfile. |

Open Project Folder (Windows Explorer) Opens project folder in Window Explorer from within RAMMS.

Help

| Friction Parameter Table (pdf) | Table of MuXi friction values in pdf format. |
| License Agreement | RAMMS License Agreement |

RAMMS Homepage Opens the RAMMS homepage at http://ramms.slf.ch in a web browser.

Update... Download RAMMS updates manually or directly from the web.

Update...

- Web Update Start web update procedure. RAMMS checks online if there is an update available.

- Get Update Manually (download to local folder) Download the update to a local folder.

- Install Update from local folder Install the update from a local folder.

Register New RAMMS Module Register your new RAMMS::DEBRIS FLOW license here.

Advanced...

- Color Tables – View Available Color Tables Choose a different type of color scheme for your colorbar.

- Additional Preferences - Edit Only for experts. Please contact ramms@slf.ch if you have questions about the additional preferences.

- Reset General Preferences Reset your general preferences (working directory, map directory etc.).

- Install C++ Libraries It is possible, that the Visual C++ Redistributable libraries for Visual Studio 2015 (x64) are not installed on your PC/laptop. These libraries are needed to run RAMMS. In case they are missing, you are not able to run simulations. Run this function to install these libraries.

- Logging Checkbox. Switch logging on or off.
### CHAPTER 5: PROGRAM OVERVIEW

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AutoWebUpdate</strong></td>
<td>Checkbox. Switch AutoWebUpdate on or off. If AutoWebUpdate is on, then RAMMS will check for updates whenever you start RAMMS.</td>
</tr>
<tr>
<td><strong>Hardware Rendering</strong></td>
<td>Checkbox. Switch hardware rendering on or off. If hardware rendering is switched on, then all graphical rendering is done by your hardware, otherwise by IDL (RAMMS). It is suggested to switch hardware rendering on.</td>
</tr>
<tr>
<td><strong>Curvature</strong></td>
<td>Checkbox. Switch curvature on or off. See section 3.1.4 on page 15 for more information about curvature.</td>
</tr>
<tr>
<td><strong>Technical Support Information</strong></td>
<td>If you have a problem using RAMMS, please send us the information from the Technical Support Information together with any error screenshots from RAMMS.</td>
</tr>
</tbody>
</table>

**RAMMS Changelog**

Information about the RAMMS releases in pdf format.

**About RAMMS**

About RAMMS information
5.1.2 Horizontal toolbar

- **Project wizard**: open avalanche wizard for creating a new avalanche project. (Ctrl + W)
- **Open input file**: (Ctrl + O)
- **Open simulation**: (Ctrl + A)
- **INPUT**: Save copy as: save the active file under a new name.
- **INPUT and OUTPUT**: Close: close the active file.
- **Print**: displays the Windows print manager.
- **Undo, Redo**.
- **Arrow (move and resize), Rotate, Move**.
- **Simulation Results**: Choose this function and move the arrow over the topography \( \rightarrow x \), \( y \)- and \( z \)-Coordinates of the mouse position are shown in the lower right status bar (see Figure 5.11 on page 88).
- **OUTPUT**: If you move the arrow over the simulation data, the active parameter is shown as well (see Figure 5.11 on page 88). If you click once with the left mouse button at a point of interest, a new window pops up called ‘RAMMS::AVALANCHE Time Plot <Active Parameter>’.
- **INPUT, 2D**: Draw new polygon shapefile: specify new polygon-points by clicking the left mouse button, finish with a right mouse click. The user is asked if he wants to draw more polygons. At last, he has to specify a new filename for the polygon shapefile.
- **INPUT, 2D**: Draw new calculation domain: specify a new calculation domain polygon by clicking with left mouse button, finish with a right mouse click. A dialog box will then ask the user for a new domain name (e.g. domain), and a polygon shapefile is saved.
- **OUTPUT, 2D**: Line Profile: Select the topography, until the Line-Profile-Button is active. Click the button and then move the cursor to the start point of your profile. Click the left mouse button and move the cursor to the next position of your profile. Finish with a right mouse button click. A new window pops up called ‘RAMMS::AVALANCHE Line Profile Plot Active Parameter’. This line profile plot is linked to your simulation. If you change the parameter or if you change the max-value in the avalanche panel, the changes are adapted in the line profile plot too. When animating the simulation, the line profile is animated too.
- **2D**: Measure distance and angle: Click with left mouse button; distance and angle between clicks is shown in the lower right status bar. Finish with a right mouse click.
- **INPUT, 2D**: View and Edit Release Areas.
- **Zoom tools**.
- **Annotation tools**, text, line, rectangle, oval, polygon, freehand. They can be activated and deactivated in the additional preferences.

Preferences → Advanced... → Edit → Annotations
### CHAPTER 5 : PROGRAM OVERVIEW

<table>
<thead>
<tr>
<th>INPUT</th>
<th>Create new MuXi File (Automatic Procedure).</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Analysis of the input DEM: Slope Angle, Curvature and Contour Plots. Remove visualization by clicking the button again.</td>
</tr>
<tr>
<td>OUTPUT</td>
<td>Show maximum values of the simulation results: Max Flow Height, Max Flow Velocity and Max Pressure.</td>
</tr>
<tr>
<td>OUTPUT, 2D</td>
<td>Create a time plot for the last point location.</td>
</tr>
<tr>
<td>OUTPUT</td>
<td>Export the results to ASCII grid.</td>
</tr>
<tr>
<td></td>
<td>Open project folder in Windows Explorer.</td>
</tr>
<tr>
<td></td>
<td>Add/change maps/orthophotos.</td>
</tr>
</tbody>
</table>
### 5.1.3 Vertical toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Add data to visualization (*.shp, *.asc).</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Show/hide lights.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Show/hide mesh.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>INPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Show/hide colorbar.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Show map.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Show image.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>INPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Stop/Pause Simulation ( ).</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Create a screenshot of the main window.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>OUTPUT</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Change RAMMS Additional Preferences.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Edit dataspace properties.</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Change RAMMS preferences (e.g. working directory).</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Change view to 2D / Change view to 3D ( ).</td>
</tr>
<tr>
<td><img src="image" alt="Vertical toolbar icon" /></td>
<td>Refresh visualization (if stuck).</td>
</tr>
</tbody>
</table>
CHAPTER 5 : PROGRAM OVERVIEW

5.1.4 Main window

The RAMMS GUI (Graphical User Interface) consists of two main regions, see Figure 5.2:

1. Main visualization window
2. Information panel, see section below.

![Main visualization window and information panel.](image)

Figure 5.2: Main visualization window and information panel.
5.1.5 Panel

An AVALANCHE panel is displayed on the right side of the RAMMS GUI (Figure 5.2), and consists of five tabs (Files, General, Display, Volumes and Region).

Files tab

The Files tab (Figure 5.3) shows a file tree with nodes for polygon shapefiles (Polygon, *.shp), MuXi-files (MuXi, *.asc) and calculation domain files (Domain, *.shp). See section 3.4.1 on page 26 on how to use the Files tab.
CHAPTER 5 : PROGRAM OVERVIEW

General tab

The General tab (Figure 5.4) shows important simulation parameters, such as: nr. of nodes, nr. of cells, end time (s), dump-step (s), grid resolution (m) and density (kg/m$^3$). In input mode, for handling and visualization purposes, the topographic information is resampled, such that there are only ca. 50’000 grid cells remaining (see Visualization Resampling Remarks in Figure 5.4, red box). This does not influence any simulation at all, it simply makes the users life easier to zoom and rotate the topography.

![Figure 5.4: Avalanche panel – General tab](image)
CHAPTER 5: PROGRAM OVERVIEW

Display tab

The Display tab (Figure 5.5) shows parameters that are important for the display of results and polygon shapefiles, such as Min_Value, Max_Value, Nr_of_Colors and Transparency. Always confirm with ENTER (return key) when changing a value! Additionally, the PARAMETER line states the visible parameter (e.g. Flow height (m) in Figure 5.5, red box).

![Avalanche panel – Display tab](image)

Figure 5.5: Avalanche panel – Display tab

The Min and Max values as well as the number of colors influence directly the colorbar and the visualization. The transparency changes the visibility of the result: 0% means no transparency, 100% means total transparency, see figure below (Figure 5.6). The colorbar is divided into N (nr. of colors) different colors, where the lowest color is normally not displayed. The bottom line informs the user of the range of values that are not displayed in the current visualization (only in output mode).

![No transparency (left) and 40% transparency (right) of simulation result.](image)

Figure 5.6: No transparency (left) and 40% transparency (right) of simulation result.
CHAPTER 5 : PROGRAM OVERVIEW

Volumes tab

The Volumes tab (Figure 5.7) gives the user information about

- projected release area (m²)
- inclined (3D) release area (m²)
- release volume (m³, estimated in input mode)
- release mass (t, input) / flow volume (m³, output)

![Figure 5.7: Avalanche panel – Volumes tab](image)

Click the *Update avalanche volume* button (in output mode, red box) to show the flow volume.
CHAPTER 5 : PROGRAM OVERVIEW

Region tab

The Region tab (Figure 5.8) gives information about min and max X-, Y-coordinates and the altitude limits as well as information about the region area in km².

![Avalanche panel – Region tab](image)

Figure 5.8: Avalanche panel – Region tab

5.1.6 Time step slider

The time slider can be moved manually to change the active time (only in output mode).

![Figure 5.9: The active time (20s) is shown in the time slider.](image)

5.1.7 Left status bar

The left status bar is used to display status information for operations or informational messages pertaining to the currently selected surface or manipulators.

![Figure 5.10: Status information shown in the left status bar.](image)
5.1.8 Right status bar

The right status bar is used to display the position of the cursor within the surface and additional simulation results at the position of the cursor.

![Image of position information and simulation results](image1.png)

Figure 5.11: Position information and simulation results in the right status bar.

5.1.9 Colorbar

In general, the colorbar appears at the right edge of the main window (Fig. 5.1) and can be moved and resized (see section 3.4.4 on page 31).

![Image of colorbar](image2.png)

Figure 5.12: Colorbar
6 References and further reading

6.1 References

Maps and aerial images

⇒ All topographic base maps and aerial images are reproduced © 2010 swisstopo(© BA091601).

Literature


6.2 Publications

The development of RAMMS is based on scientific findings published in international scientific journals. A list of the most important scientific publications about RAMMS and its applications can be found on our homepage at http://ramms.slf.ch, section RESOURCES-Publications.

7 Appendix

7.1 MuXi-Table

The following friction parameters (µ and ξ values) are used in RAMMS. Return period and volume category can be changed in Input ⇒ Global Parameters.
<table>
<thead>
<tr>
<th></th>
<th>Flow 100-Yr</th>
<th>Flow 50-Yr</th>
<th>Flow 25-Yr</th>
<th>Flow 10-Yr</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1000</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>1500</td>
<td>0.05</td>
<td>0.05</td>
<td>0.05</td>
<td>0.05</td>
</tr>
<tr>
<td>2000</td>
<td>0.10</td>
<td>0.10</td>
<td>0.10</td>
<td>0.10</td>
</tr>
<tr>
<td>2500</td>
<td>0.15</td>
<td>0.15</td>
<td>0.15</td>
<td>0.15</td>
</tr>
<tr>
<td>3000</td>
<td>0.20</td>
<td>0.20</td>
<td>0.20</td>
<td>0.20</td>
</tr>
<tr>
<td>3500</td>
<td>0.25</td>
<td>0.25</td>
<td>0.25</td>
<td>0.25</td>
</tr>
<tr>
<td>4000</td>
<td>0.30</td>
<td>0.30</td>
<td>0.30</td>
<td>0.30</td>
</tr>
<tr>
<td>4500</td>
<td>0.35</td>
<td>0.35</td>
<td>0.35</td>
<td>0.35</td>
</tr>
<tr>
<td>5000</td>
<td>0.40</td>
<td>0.40</td>
<td>0.40</td>
<td>0.40</td>
</tr>
<tr>
<td>5500</td>
<td>0.45</td>
<td>0.45</td>
<td>0.45</td>
<td>0.45</td>
</tr>
<tr>
<td>6000</td>
<td>0.50</td>
<td>0.50</td>
<td>0.50</td>
<td>0.50</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Flow Parameters**

- **Small (0.00 - 0.10 m³/s)**
- **Large (> 0.50 m³/s)**
- **Medium (0.30 - 0.45 m³/s)**
- **Small to Medium (0.10 - 0.30 m³/s)**

**Flow Classifications**

- **Small**
- **Large**
- **Medium**
- **Small to Medium**

**Flow Adjustments**

- **Flow Adjustments (0.00 - 0.60 m³/s)**
### Chapter 7: Appendix

<table>
<thead>
<tr>
<th>Category</th>
<th>30-Year</th>
<th>100-Year</th>
<th>300-Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Medium</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>High</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Fiction Parameters

- **RMSI**: Available 1.4

#### Small Available (5 - 25,000 m²)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>30-Year</th>
<th>100-Year</th>
<th>300-Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Height</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Below</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Above</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Undamaged</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Channeled</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Only</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Legend**

- **Red**: Area (m²)
- **Blue**: Area (m²)
- **Green**: Area (m²)

---

**Notes**

- **Table**
- **Diagram**
List of Figures

FIGURE 2.1: INSTALLATION - WELCOME DIALOG WINDOW .......................................................... 5
FIGURE 2.2: INSTALLATION - README DIALOG WINDOW .......................................................... 5
FIGURE 2.3: INSTALLATION - LICENSE AGREEMENT DIALOG WINDOW .................................. 6
FIGURE 2.4: INSTALLATION - DESTINATION DIRECTORY DIALOG WINDOW ................................. 6
FIGURE 2.5: INSTALLATION - INSTALLING FILES DIALOG WINDOW .......................................... 7
FIGURE 2.6: INSTALLATION - FINISHED INSTALLING FILES DIALOG WINDOW ............................. 7
FIGURE 2.7: INSTALLATION - FINISHED INSTALLATION DIALOG WINDOW .................................... 8
FIGURE 2.8: IDL VISUAL STUDIO MERGE MODULES - WELCOME DIALOG WINDOW ..................... 8
FIGURE 2.9: IDL VISUAL STUDIO MERGE MODULES - READY TO INSTALL THE PROGRAM .............. 9
FIGURE 2.10: IDLVISUAL STUDIO MERGE MODULES - INSTALLING ............................................. 9
FIGURE 2.11: INSTALLATION - DESTINATION DIRECTORY DIALOG WINDOW .............................. 10
FIGURE 2.12: RAMMS ICON ........................................................................................................ 10
FIGURE 2.13: RAMMS PROGRAM GROUP ....................................................................................... 10
FIGURE 2.14: RAMMS START WINDOW ......................................................................................... 11
FIGURE 2.15: RAMMS LICENSING WINDOW .................................................................................... 11
FIGURE 2.16: ENTER USER NAME AND COMPANY NAME .......................................................... 12
FIGURE 2.17: PERSONAL LICENSE REQUEST FILE RAMMS_DBF_REQUEST_TESTNAME.TXT ............ 12
FIGURE 2.18: PERSONAL LICENSE KEY FILE RAMMS_LICENSE_MUSTER_TEST.TXT ...................... 13
FIGURE 3.1: EXAMPLE ESRI ASCII GRID ....................................................................................... 14
FIGURE 3.2: EXAMPLE ASCII X, Y, Z SINGLE SPACE DATA .......................................................... 14
FIGURE 3.3: THE SAME PROJECT EXTENT (AREA OF INTEREST) CAN BE USED TO CALCULATE DIFFERENT
SCENARIOS WITH DIFFERENT INPUT PARAMETERS ..................................................................... 15
FIGURE 3.4: RELATION BETWEEN NORMAL AND SHEAR STRESS. LEFT: YIELD STRESS N₀ SERVES TO INCREASE
THE SHEAR STRESS FOR HIGHER NORMAL PRESSURES. AT LOW NORMAL PressURES (SMALL FLOW
HEIGHTS) THE SHEAR STRESS INCREASES RAPIDLY FROM S=0 TO $S=N_\theta$. THE SLOPE OF THE 'S VS N'
RELATION REMAINS $\mu$, WHEN THE NORMAL PRESSURES ARE LARGE. RIGHT: IF $\mu=0$, WE HAVE A VISCO-
PLASIC BEHAVIOUR. ...................................................................................................................... 17
FIGURE 3.5: RAMMS AUTOMATIC MUXI PROCEDURE .................................................................. 18
FIGURE 3.6: RAMMS GLOBAL PARAMETERS .............................................................................. 19
FIGURE 3.7: GENERAL TAB OF RAMMS PREFERENCES .............................................................. 20
FIGURE 3.8: AVALANCHE TAB OF RAMMS PREFERENCES .......................................................... 20
FIGURE 3.9: RAMMS PREFERENCES ............................................................................................ 21
FIGURE 3.10: BROWSE FOR THE CORRECT FOLDER .................................................................... 21
FIGURE 3.11: RAMMS PROJECT WIZARD STEP 1 OF 4 .............................................................. 22
FIGURE 3.12: STEP 1 OF THE RAMMS PROJECT WIZARD PROJECT INFORMATION .................. 23
FIGURE 3.13: WINDOW TO BROWSE FOR A NEW PROJECT LOCATION ....................................... 23
FIGURE 3.14: STEP 2 OF THE RAMMS PROJECT WIZARD: GIS INFORMATION .............................................................. 23
FIGURE 3.15: PROJECT COORDINATES: LOWER LEFT AND UPPER RIGHT CORNER OF PROJECT AREA ......................... 24
FIGURE 3.16: STEP 3 OF THE RAMMS PROJECT WIZARD: PROJECT BOUNDARY COORDINATES .............................. 24
FIGURE 3.17: STEP 4 OF THE RAMMS PROJECT WIZARD: PROJECT SUMMARY ......................................................... 24
FIGURE 3.18: CREATED PROJECT FILES .................................................................................................................. 25
FIGURE 3.20: SELECTED FILE (RELEASE.SHP) ON THE RIGHT IS SHOWN IN THE VISUALIZATION ............................... 26
FIGURE 3.21: RIGHT-CLICK MENUS SHAPEFILE PROPERTIES, RELEASE PROPERTIES, IMPORT FOREST FROM SHAPEFILE, DEPOSITION ANALYSIS (ONLY OUTPUT) AND DELETE ......................................................... 27
FIGURE 3.22: USE SHAPEFILE PROPERTIES TO CHANGE LINE THICKNESS, COLOR OR LINESTYLE ...................... 27
FIGURE 3.23: WINDOW TO CHOOSE MAP IMAGE ........................................................................................................ 29
FIGURE 3.24: ACTIVE PROJECT WITH LINES AND CORNERS FOR RESIZING ................................................................. 29
FIGURE 3.25: ACTIVE PROJECT WITH ROTATION AXES ................................................................................................. 30
FIGURE 3.26: 3D VIEW OF EXAMPLE MODEL ............................................................................................................... 31
FIGURE 3.27: 2D VIEW OF EXAMPLE MODEL ................................................................................................................ 31
FIGURE 3.28: THE DISPLAY TAB ..................................................................................................................................... 32
FIGURE 3.29: THE COLORBAR PROPERTIES WINDOW ................................................................................................. 32
FIGURE 3.30: ABOUT RAMMS ....................................................................................................................................... 34
FIGURE 3.31: DRAWING A NEW RELEASE AREA .......................................................................................................... 36
FIGURE 3.32: ABOUT ....................................................................................................................................................... 37
FIGURE 3.33: VIEW/EDIT RELEASE AREA ....................................................................................................................... 38
FIGURE 3.34: ABOUT ....................................................................................................................................................... 39
FIGURE 3.35: ABOUT ....................................................................................................................................................... 40
FIGURE 3.36: RELEASE AREA AND VOLUME INFORMATION ............................................................................................. 40
FIGURE 3.37: CALCULATION DOMAIN IN GREEN ENCLOSURES THE AREA OF INTEREST AND REDUCES CALCULATION TIME IN COMPARISON WITH THE DEFAULT RECTANGULAR DOMAIN WHICH IS AUTOMATICALLY GENERATED ........................................................................................................ 41
FIGURE 3.38: INPUT FILE WITH BIG CALCULATION DOMAIN .......................................................................................... 42
FIGURE 3.39: MAX FLOW HEIGHT OF A 10M SIMULATION WITH CONSTANT MU AND XI ................................................. 42
FIGURE 3.40: ENVELOPE SHAPEFILE OF MAX FLOW HEIGHT EXTENT ........................................................................ 43
FIGURE 3.41: INPUT FILE WITH OPTIMIZED CALCULATION DOMAIN (ENVELOPE SHAPEFILE) ................................ 43
FIGURE 3.42: MAX FLOW HEIGHT RESULT OF A 5M SIMULATION WITH VARIABLE MUXI-FILE ........................................... 44
FIGURE 3.43: IMPORT FOREST FROM SHAPEFILE ........................................................................................................ 45
FIGURE 3.44: RAMMS GLOBAL PARAMETERS ............................................................................................................. 46
FIGURE 3.45 GENERAL INFORMATION ....................................................................................................................... 48
FIGURE 3.46: PARAMETER TAB ....................................................................................................................................... 49
FIGURE 3.47: FRICTION VALUES MU AND XI ................................................................. 50
FIGURE 3.48: RELEASE INFORMATION .......................................................................... 50
FIGURE 3.49: CALCULATION STATUS WINDOW .............................................................. 51
FIGURE 3.50: BACKGROUND SIMULATION MODE WINDOW ............................................ 51
FIGURE 4.1: MAIN WINDOW IN OUTPUT MODE ............................................................... 52
FIGURE 4.2: OUTFLOW VOLUME ALERT ......................................................................... 52
FIGURE 4.3: OUTPUT LOGFILE ..................................................................................... 53
FIGURE 4.4: RAMMS PROJECT INPUT LOG FILE ............................................................ 54
FIGURE 4.5: REGION EXTENT (X-, Y- AND Z-COORDINATES, TOTAL PROJECTED AREA) ............................................................... 54
FIGURE 4.6: RESULTS: MAXIMUM VALUES OF FLOW HEIGHT (LEFT), VELOCITY (MIDDLE) AND PRESSURE (RIGHT) ... 56
FIGURE 4.7: QUASI 3D-VISUALIZATION OF FLOW HEIGHT (LEFT: EXAGGERATION 1; RIGHT: EXAGGERATION 5) ........................................ 56
FIGURE 4.8: LINE PROFILE PLOT .................................................................................... 58
FIGURE 4.9: LINE PROFILE PERPENDICULAR TO FLOW DIRECTION ............................... 59
FIGURE 4.10: LINE PROFILE ALONG THE FLOW DIRECTION ......................................... 59
FIGURE 4.11: TIME PLOT WINDOW .............................................................................. 60
FIGURE 4.12: DEPOSITION ANALYSIS OF REGION OF INTEREST ..................................... 61
FIGURE 4.13: RESULT OF A DEPOSITION ANALYSIS. TOTAL DEPOSITION VOLUME (M³) AS WELL AS SOME STATISTICAL VALUES ARE SHOWN (MIN, MEAN, MAX) ......................................................... 62
FIGURE 4.14: SUMMARY OF MOVING MASS .................................................................. 63
FIGURE 4.15: STOPPING BEHAVIOUR OF A RAMMS SIMULATION. SMALL THRESHOLD VALUES MAY LEAD TO UNLILY SLOW CREEPING OF THE MATERIAL. IN THE EXAMPLE SHOWN IN THE FIGURE ABOVE THE STOPPING CRITERIA IS SET TO 0%. ...................................................................................... 64
FIGURE 4.16: STOPPING BEHAVIOUR OF A RAMMS SIMULATION. IN THIS EXAMPLE THRESHOLD VALUES <2% LEAD TO NUMERICAL DIFFUSION OF THE SIMULATION RESULTS. A THRESHOLD VALUES BETWEEN 3-5% SEEM TO BE APPROPRIATE IN THIS CASE .......................................................................................... 64
FIGURE 4.17: RELEASE AREA WHERE A DAM IS SUPPOSED TO BE BUILT ......................... 66
FIGURE 4.18: DAM ........................................................................................................ 66
FIGURE 4.19: SELECT NEW XYZ-FILE WITH DAM INFORMATION .................................. 66
FIGURE 4.20: SIMULATION WITHOUT (LEFT) AND WITH (RIGHT) A DAM ................. 67
FIGURE 4.21: DAM WITH GRADUALLY RISING SIDE WALLS ........................................... 67
FIGURE 5.1: GRAPHICAL USER INTERFACE (GUI) ......................................................... 69
FIGURE 5.2: MAIN VISUALIZATION WINDOW AND INFORMATION PANEL .................. 82
FIGURE 5.3: AVALANCHE PANEL – FILES TAB ................................................................ 83
FIGURE 5.4: AVALANCHE PANEL – GENERAL TAB ....................................................... 84
FIGURE 5.5: AVALANCHE PANEL – DISPLAY TAB ........................................................... 85
FIGURE 5.6: NO TRANSPARENCY (LEFT) AND 40% TRANSPARENCY (RIGHT) OF SIMULATION RESULT ......................................................... 85
FIGURE 5.7: AVALANCHE PANEL – VOLUMES TAB ....................................................... 86
94
List of tables

TABLE 3.1: LISTING OF FILES AND DIRECTORIES CREATED WITH A NEW RAMMS::AVALANCHE PROJECT......... 25

Third-Party Software

The following third-party software components are used in RAMMS:

7-zip:

- We sometimes use 7za.exe to zip data.
- 7-zip is licensed under GNU LGPL.
- The source code of 7-zip is available at www.7-zip.org.

Mtee:

- Mtee is a Win32 console application that sends any data it receives to stdout and to any number of files.
- Mtee is released under MIT License https://ritchielawrence.github.io/mtee/.
Index

μ
μ and ξ 18

A
Add Deposition to DEM 68
AutoWebUpdate 13, 78

B
Background Color 21

C
Calculation domain 41
Calculation parameters 19
Cohesion 16
Colorbar 31
Curvature 17

D
Dam 65
Delay 38
Delete 26
Deposition analysis 26, 61
Digital Elevation Model (DEM) 14
Display tab 85

F
Files tab 83
Forest 19
Friction 15
Friction parameters μ and ξ 44

G
General tab 84
GEOTIFF 14
GIF animation 61, 62
Global parameters 19, 46
GUI 69

H
Horizontal toolbar 79

I
Import forest from shapefile 26
Input logfile 54

Installation 4

L
License request file 12
Licensing 11
Line profile 57, 58

M
MuXi-file 47
MuXi-Table 89

N
New project 22

O
Output Log File 53
Output logfile 53

P
Panel 83
Preferences 20
Program overview 69
Region tab 87
Release area(s) 35
Release properties 26
Results 52
Run a calculation 48

S
Secondary avalanche release 38
Shapefile properties 26
Status bar 88
Stopping 63
System requirements 4

T
Time plot 57, 60
Time step slider 87

U
Update 13

96
Vertical toolbar  81
Voellmy  16
Volumes tab  86
Yield stress  16
Working directory  21