RAMMS::AVALANCHE User Manual

RAMMS
rapid mass movement simulation

A numerical model for snow avalanches in research and practice

User Manual v1.8.0
AVALANCHE
WSL-Institut für Schnee- und Lawinenforschung SLF
WSL Institut pour l‘étude de la neige et des avalanches SLF
WSL Instituto per lo studio della neve e delle valanghe SLF
WSL Institute for Snow and Avalanche Research SLF

Title picture: Vallée de la Sionne, WSL

Manuscript update
October 2022

Table of Content
1

2

Introduction ........................................................................................................................ 1
1.1

Motivation .................................................................................................................. 1

1.2

RAMMS ........................................................................................................................ 2

1.3

Learning by doing ........................................................................................................ 3

Installation and Setup ......................................................................................................... 4
2.1

System requirements .................................................................................................. 4

2.2

Installation ................................................................................................................... 4

2.3

Licensing .................................................................................................................... 11

2.4

First start .................................................................................................................... 11

2.4.1

Personal license request file .............................................................................. 12

2.4.2

Getting the personal license key ..................................................................... 12

2.4.3

License Transfer.................................................................................................. 13

2.5
3

Update ....................................................................................................................... 13

Setting up a simulation ..................................................................................................... 14
3.1

Preparations ............................................................................................................. 14

3.1.1

Topographic data - Digital Elevation Model (DEM)....................................... 14

3.1.2

Project and Scenarios ........................................................................................ 15

3.1.3

Release information ........................................................................................... 15

3.1.4

Friction information ........................................................................................... 16

3.1.5

Global parameters .............................................................................................. 20

3.1.6

Forest information ........................................................................................... 20

3.1.7

Calculation parameters ...................................................................................... 20

3.2

Preferences .............................................................................................................. 21

3.3

Creating a new project .............................................................................................. 23

3.4

Working with the RAMMS GUI .................................................................................. 27

3.4.1

Open input- and output-files............................................................................. 27

3.4.2

Visualizing shapefiles, MuXi-files and domain-files .......................................... 27
i

3.4.3

Hillshade visualization ....................................................................................... 30

3.4.4

Changing maps and orthophotos (aerial images) ............................................. 31

3.4.5

Moving, resizing, rotating, viewing ................................................................... 32

3.4.6

Colorbar .............................................................................................................. 34

3.4.7

How to save input files and program settings .............................................. 36

3.4.8

About RAMMS................................................................................................... 37

3.5

4

3.5.1

Release area(s) ................................................................................................... 38

3.5.2

Calculation Domain ............................................................................................ 43

3.5.3

Friction parameters µ and ξ ............................................................................... 47

3.5.4

How to run a calculation .................................................................................... 50

3.5.5

How to run BATCH calculations ......................................................................... 55

Results ............................................................................................................................... 56
4.1

Project information ................................................................................................... 57

4.2

Visualization and analysis of results .......................................................................... 59

4.2.1

Visualize different parameters ........................................................................... 59

4.2.2

Line profile and time plot ................................................................................... 61

4.2.3

Deposition analysis ............................................................................................. 65

4.2.4

Google Earth Export ........................................................................................... 67

4.2.5

Creating an image or a GIF animation................................................................ 70

4.2.6

Stopping criteria ................................................................................................. 70

4.3

5

Running a simulation .............................................................................................. 38

Adding structures or deposition to DEM ................................................................... 73

4.3.1

Creating a dam ................................................................................................... 73

4.3.2

Creating a new DEM with avalanche deposition ............................................... 76

Program overview ............................................................................................................. 77
5.1

The Graphical User Interface (GUI) ........................................................................... 77

5.1.1

The menu bar ..................................................................................................... 78

5.1.2

Horizontal toolbar .............................................................................................. 87

5.1.3

Vertical toolbar................................................................................................... 89

5.1.4

Main window ...................................................................................................... 90

5.1.5

Panel ................................................................................................................... 90

6

7

5.1.6

Time step slider .................................................................................................. 95

5.1.7

Left status bar..................................................................................................... 95

5.1.8

Right status bar .................................................................................................. 95

5.1.9

Colorbar .............................................................................................................. 96

References and further reading ........................................................................................ 97
6.1

References ................................................................................................................ 97

6.2

Publications .............................................................................................................. 97

Appendix ........................................................................................................................... 98
7.1

MuXi-Table................................................................................................................. 98

List of figures .......................................................................................................................... 101
List of tables ........................................................................................................................... 104
Third-Party Software .............................................................................................................. 104
Index…………………………………………………………………………………………………………………………………105
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Introduction

In the field of natural hazards there is an increasing need for process models to help understand the
motion of geophysical movements. These models allow engineers to predict the speed and mass of
hazardous movements in complex terrain. Such models are especially helpful when processing mitigation measures, such as avalanche dams or snow sheds. Hazard mapping is an especially important
application in Switzerland and other mountainous countries. An accurate prediction of runout distances, flow velocities and impact pressures in general three-dimensional terrain is the driving motivation for the development of dynamical mass movement models. Although helpful and well-liked by
users, one-dimensional models such as AVAL-1D require that the primary flow direction and flow
width must be defined by the user in advance. This is often difficult, especially in open terrain, or in
terrain consisting of several possible flow channels. Furthermore, flow interaction with catching and
deflecting dams cannot be accurately modeled using one-dimensional simulation codes.
RAMMS (Rapid Mass Movement Simulation) is a two-dimensional, state-of-the-art numerical simulation model to calculate the motion of geophysical mass movements (snow avalanches, rockslide,
debris flows and shallow landslides) from initiation to runout in three-dimensional terrain. It was
designed to be used in practice by hazard engineers who need solutions to real, everyday problems.
It is coupled with a user-friendly visualization tool that allows them to easily access, display and analyze simulation results. New constitutive models have been developed and implemented in RAMMS,
thanks to calibration and verification at full scale tests at sites such as Vallée de la Sionne. These
models allow the application of RAMMS to solve both large, extreme avalanche events as well as
smaller mass movements such as hillslope debris flow and shallow landslides.
RAMMS is developed since 2010 by the RAMMS team at the WSL Institute for Snow and Avalanche
Research SLF. This manual describes the features of the RAMMS program – allowing beginners to get
started quickly as well as serving as a reference to expert users.
The RAMMS web page https://ramms.slf.ch provides useful information such as a forum, frequently
asked questions (FAQ) or recent software updates. Please visit this web page frequently to stay up to
date!

1.1 Motivation
Mitigation of natural hazards relies increasingly on numerical process models to predict the area
inundated by rapid geophysical mass movements. These movements include
•
•
•
•
•

snow avalanches,
torrent based debris flows and hillslope debris flows,
mudslides,
ice avalanches and glacier lake outbreaks
rockfalls and rock avalanches.

Process models are used by engineers to predict the speed and reach of these hazardous movements
in complex terrain. The preparation of hazard maps is a primary application. The models are especially helpful when proposing technical mitigation measures, such as dams and embankments or rockfall
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protection barriers. The models allow hazard engineers to optimize limited financial resources by
studying the influence of different hazard scenarios on defense options.

1.2 RAMMS
The RAMMS (RApid Mass Movements Simulation) software system contains three process modules:
•
•
•

RAMMS::AVALANCHE
RAMMS::DEBRISFLOW
RAMMS::ROCKFALL

The RAMMS::AVALANCHE and RAMMS::DEBRISFLOW modules are designed for flow phenomena
containing fast moving particulate debris of snow and rocks. In the avalanche module, the interstitial
fluid is air, whereas in the debris flow module the interstitial fluid is mud. The RAMMS::AVALANCHE
and RAMMS::DEBRISFLOW models are used to calculate the motion of the movement from initiation
to runout in three-dimensional terrain. The models use depth-averaged equations and predict the
slope-parallel velocities and flow heights. This information is sufficient for most engineering applications. Information in the slope-perpendicular direction (e.g. mass and velocity distribution) is lost;
however, this is seldom of practical interest. Both models require an accurate digital representation
of the terrain. Engineers specify initial conditions (location and size of the release mass) and friction
parameters, depending on terrain (e.g. roughness, vegetation) and material (e.g. snow, ice or mud
content of the debris flow).
The RAMMS::ROCKFALL module is used to study the rigid body motion of falling rocks. The model
predicts rock trajectories in general three-dimensional terrain. Rock trajectories are governed by the
interaction between the rock and ground. The model contains six primary state variables: three
translational speeds and three rotational velocities of the falling rock. From these, kinetic energy,
runout distance and jump heights can be derived. Generalized rock shapes are modeled. Rock orientation and rotational speed are included in the rock/ground interaction. The RAMMS::ROCKFALL
module is therefore fundamentally different from the RAMMS::AVALANCHE and
RAMMS::DEBRISFLOW modules because it is based on hard-contact, rigid-body Lagrangian mechanics, not Eulerian flow mechanics. It also differs from existing rockfall modules because the
rock/ground interaction is not governed by simple rebound mechanics, but frictional (dissipative)
rock/ground interactions. These govern the onset of rock jumping. The RAMMS::ROCKFALL module
predicts all rigid-body motions – rock sliding, rolling, jumping and skipping.
In all RAMMS modules, new constitutive models have been developed and implemented, thanks to
calibration and verification at full scale test sites such as St. Léonard/Walenstadt (rockfall, mitigation measures), Vallée de la Sionne (snow avalanches) and Illgraben (debris flow).
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1.3 Learning by doing
This manual provides an overview of RAMMS::AVALANCHE. Exercises exemplify different steps in
setting up and running a RAMMS simulation especially in Chapter 3 ‘Setting up a Simulation’. However, to get the most from the manual, we suggest reading it through while simultaneously having the
RAMMS program open, learning by doing. We assume RAMMS users to have a basic level of familiarity with Windows-based programs, commands and general computer terminology. We do not describe the basics of windows management (such as resizing or minimizing). RAMMS windows, click
options and input masks are similar to other Windows based programs and can be used, closed,
reduced or resized in the same way.

DISCLAIMER
RAMMS is intended to be used as a tool to support experienced users. The interpretation of the simulation results has to be done by an avalanche expert who is familiar with the local as well as with
the topographic and geological situation of the investigation area. In no event shall SLF/WSL be liable
for any damage or lost profits arising, directly or indirectly, from the use of RAMMS. Swiss law applies. Court of jurisdiction is Davos. If you encounter problems, please contact ramms@slf.ch.
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Installation and Setup
2.1 System requirements

We recommend the following minimum
RAMMS::AVALANCHE:
•

system

requirements

for

running

Operating Systems: Windows 8, 10 and 11 (64-bit)
32-bit systems (Win XP) are not supported anymore

•

RAM (memory): 4 GB (more recommended)

•

CPU: > 1 GHz, 2 cores or more recommended

•

Disk space: ca. 220 MB needed for the software

2.2 Installation
Please download the RAMMS::AVALANCHE setup file “ramms_user_setup_64.zip” from
https://ramms.slf.ch/en/modules/avalanche.html (Downloads tab at the bottom of page).
Direct download link: https://ramms.slf.ch/ramms/downloads/ramms_user_setup_64.zip
Please do the following steps before beginning to install RAMMS:
•
•
•

•
•

Click on the path given above or copy the path to any browser. A window pops up and the
automatic download of the file ramms_user_setup_64.zip starts after clicking Yes.
Unzip the file to a temporary location.
You must have Administrator privileges on the target machine. If you do not have such
privileges, the installer cannot modify the system configuration of the machine and the
installation will fail. Note that you do not need Administrator privileges to run RAMMS afterwards.
Read first, install afterwards! Please read the whole installation process once, before you
begin the installation.
Start the file “ramms<version>_user_setup_64.exe”.

4

CHAPTER 2: INSTALLATION AND SETUP
Step 1: Welcome
The welcome dialog introduces you to the English setup program and will guide you through the
installation process. Click Next to continue.

Figure 2-1: Installation - welcome dialog window.

Step 2: Readme
Short introduction to RAMMS. Click Next to continue.

Figure 2-2: Installation - Readme dialog window.
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Step 3: Accepting the license agreement
Read the license agreement carefully and accept it by activating the check box in the lower left
corner. If you do not accept the license agreement, you are not able to proceed with the installation. After accepting the license agreement, click Next to continue the installation.

Figure 2-3: Installation - license agreement dialog window.
Step 4: Select destination directory
Choose your destination directory. This dialog shows the amount of space available on your hard disk
and required for the installation. Click Next to start the installation process.

Figure 2-4: Installation - destination directory dialog window.
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Step 5: Installing the files
RAMMS is copying the files to the destination location. The window shows the installation progress.

Figure 2-5: Installation - installing files dialog window.

Step 6: Finished installing the files
RAMMS finished copying the files. Click Next to finish the installation process.

Figure 2-6 : Installation - finished installing files dialog window.
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Step 7: RAMMS installation finished!
RAMMS successfully finished the installation. Click Finish.

Figure 2-7: Installation - finished installation dialog window.
Step 8: Welcome to IDL Visual Studio Merge Modules
To ensure that all important system libraries are installed on your target machine follow the instructions below:
The welcome dialog introduces you to the English setup program and will guide you through the
installation process of the IDL Visual Studio Merge Modules. Click Next to continue.

Figure 2-8: IDL Visual Studio Merge Modules - welcome dialog window.
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Step 9: Ready to install the program

Figure 2-9: IDL Visual Studio Merge Modules - ready to install the program.

Click Next to continue.

Step 10: Installing IDL Visual Studio Merge Modules
The wizard is installing the files. Please wait until it is finished.

Figure 2-10: IDL Visual Studio Merge Modules - installing...
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Step 11: InstallShield Wizard Completed
The wizard completed the installation. Click Finish.

Figure 2-11: Installation - destination directory dialog window.
After having successfully installed RAMMS and the necessary files on your personal computer, you
will notice the RAMMS icon on your desktop (for all users):

Figure 2-12: RAMMS icon.
Additionally, a new application folder is created in Start → Programs (for all users):

•
•

RAMMS → Run RAMMS
RAMMS → Uninstall RAMMS

Figure 2-13: RAMMS program group

10

CHAPTER 2: INSTALLATION AND SETUP

2.3 Licensing
Access to RAMMS is controlled by a personal use license. Personal use licenses are time limited
licenses tied to a single personal computer. This method of licensing requires a machine’s unique
host ID to be incorporated into a license request file. After the license request file is sent to
SLF/WSL, you will receive a license key. Entering the license key on a personal computer enables
full RAMMS functionality for the specific personal computer. For more information please visit
https://ramms.slf.ch. Alternatively, the license can be installed on a Windows Server and accessed by different users (only one at a time) by RDC (Remote Desktop Connection). This
only works for one license per module.

2.4 First start
Double-click the RAMMS icon or use Start → Programs → RAMMS → Run RAMMS to start RAMMS
for the first time. Whenever you start RAMMS, the splash screen below will pop up:

Figure 2-14: RAMMS start window.

Click on the image. It will disappear and RAMMS will start up. The following dialog window appears
(Figure 2-15 RAMMS Licensing):

Figure 2-15: RAMMS licensing window
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Figure 2-16: Enter user name and company name.

2.4.1 Personal license request file
Click the button
to create your personal license request file. In Figure 2-16 enter your full
name and the name of your company.
In the next dialog window, choose the destination directory of your personal license request file and
save it to your target machine. Your personal license request file should look similar to Figure 2-17.

Figure 2-17: Personal license request file RAMMS_DBF_request_TestName.txt

2.4.2

Getting the personal license key

You find order forms on the RAMMS website (Full License, Demo License or Student License) at
https://ramms.slf.ch/en/licenses.html. Fill in all your personal information, choose the license
period, license type and number of licenses you wish to order, attach your personal license request file(s), accept the license agreement and click Submit Order.
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An order confirmation email is sent to your email address. We then process your order and send
you an invoice. You will find all the banc details on this invoice for a banc transfer. Please let us know
if you wish to pay by credit card. After we have received your payment, we will send you your
personal license key, valid according to the license period you purchased. Your personal license key is
named in the following manner:
“A V A _20151013_TestName_TestCompany_RAMMS_TimeLicense.txt”. Open the file in a text
editor. It should look similar to
Figure 2-18 below. The filename reveals also the end date of your license period, e.g.
“20151013” = October 13th 2015.

Figure 2-18: Personal license key file RAMMS_license_Muster Test.txt

Now, restart RAMMS (as explained before). The IDL splash screen appears (Figure 2-14) and then
the dialog window of Figure 2-15 shows up (RAMMS - Licensing). Copy the license key (in this
example: AVALANCHE agjk-hmih-ik1u-jk42-l1h3) and paste it in the field LICENSE KEY (see Figure
2-15). Notice that there is the prefix AVALANCHE. This prefix is part of the license key and has to
be inserted as well! If RAMMS accepts your installation key, you successfully finished the installation.

2.4.3 License Transfer
If you want to transfer your RAMMS license to a new PC, do the following:
•
•
•
•
•

install RAMMS on the new PC
generate a new license request file
send us the new license request file TOGETHER with your old license file by email
we will then send you the new license file (email)
uninstall RAMMS from your old PC

2.5 Update
When you start RAMMS it will automatically check for updates on the internet. This can lead to an
error message, if your firewall blocks the executable idlrt.exe (this file starts the IDL-Virtual Machine
you need to run RAMMS). Please unblock this file for your firewall. You can also disable the
AutoWebUpdate-function by unchecking Help → Advanced... → AutoWebUpdate. In the same way
you can enable the AutoWebUpdate-function by checking Help → Advanced... → AutoWebUpdate.
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Setting up a simulation
3.1 Preparations

To successfully start a new RAMMS project, a few important preparations are necessary. Topographic input data (DEM in ASCII- or GEOTIFF-format), project boundary coordinates and georeferenced maps or orthophotos should be prepared in advance (.tif format and .tfw-file, maps and
orthophotos are not mandatory, but nice to have). Georeferenced datasets have to be in the same
Cartesian coordinate system (e.g. Swiss CH1903 LV03) as the DEM. Polar coordinate systems in
degree (e.g. WGS84 Longitude Latitude) are not supported. For more information about specific
national coordinate systems please contact the national topographic agency in your country.

3.1.1 Topographic data - Digital Elevation Model (DEM)
The topographic data is the most important input requirement. The simulation results depend
strongly on the resolution and accuracy of the topographic input data. Before you start a simulation,
make sure all important terrain features are represented in the input DEM. RAMMS is able to
process the following topographic data:
1. ESRI ASCII grid (Figure 3-1)
2. GEOTIFF (georeferenced information embedded within a TIFF file)
3. ASCII XYZ regular, single space data (Figure 3-2)
ASCII XYZ data (regular and irregular) can be converted within RAMMS into an ASCII or GEOTIFF grid.
A wizard will guide you through the conversion process. The following interpolation methods are
available: LINEAR or INVERSE DISTANCE.
The header of an ESRI ASCII grid must contain the information shown below in Figure 3-1.

Figure 3-1 : Example ESRI ASCII grid.

Figure 3-2: Example ASCII XYZ single space
data.
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3.1.2 Project and Scenarios
A project is defined for a region of interest. Within a project, one or more scenarios can be specified and analyzed. For every scenario, a calculation can be executed. A project consists therefore
of different scenarios (input files) with different input parameters. The basic topographic input
data is the same for every scenario. If you want to change the topographic input data (e.g.
change the input DEM resolution or the project boundary coordinates) you have to create a new
project. Other input parameters (such as release area, calculation domain, calculation grid resolution, end time or time step) can be changed for every scenario.

Figure 3-3: The same project extent (area of interest) can be used to
calculate different scenarios with different input parameters.

3.1.3 Release information
The definition of release areas and release heights have a very strong impact on the results of
RAMMS simulations. Therefore, we recommend to use reference information such as photography,
PGS measurements or field maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area.
Users can use any polygon shapefile as a release area, see section 3.5.1 on page 38. Release areas
drawn in RAMMS are saved as polygon shapefiles and can be easily imported in GIS-Software (e.g.
ArcGIS or QGIS). Shapefiles created in e.g. ArcGIS or QGIS can of course be used in RAMMS.
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3.1.4 Friction information
RAMMS employs a Voellmy-fluid friction model, which is based on the Voellmy-Salm approach (we
refer to Salm et al. 1990 [3] and Salm 1993 [4]).

Physical friction model
The physical model of RAMMS::AVALANCHE uses the Voellmy friction law. This model divides the
frictional resistance into two parts: a dry-Coulomb type friction (coefficient µ) that scales with the
normal stress and a velocity-squared drag or viscous-turbulent friction (coefficient ξ). The frictional
resistance S (Pa) is then
𝑆 = 𝜇𝑁 +

𝜌𝑔𝒖2
with 𝑁 = 𝜌ℎ gcos(𝜙)
𝜉

(3.1)

where ρ is the density, g the gravitational acceleration, φ the slope angle, h the flow height and u
the vector u = (ux,uy)T, consisting of the avalanche velocity in the x- and y-directions. The normal stress on the running surface, ρhgcos(φ), can be summarized in a single parameter N. The
Voellmy model accounts for the resistance of the solid phase (µ is sometimes expressed as the tangent of the internal shear angle) and a viscous or turbulent fluid phase (ξ was introduced by
Voellmy by using hydrodynamic arguments). The friction coefficients are responsible for the behavior of the flow. µ dominates when the flow is close to stopping, ξ dominates when the flow is
running quickly.
Throughout one simulation the friction coefficients of a calculation domain are constant. However,
you have the possibility to add up to two polygons within the calculation domain with different
friction parameters (see section 3.5.4 ”How to run a calculation” on page 50.)
The Voellmy friction model has found wide application in the simulation of mass movements,
especially snow avalanches. For modeling snow avalanches the Voellmy model has been in use in
Switzerland for many years and a set of standard parameters is available.

Cohesion
Since Version 1.6.20 the basic Voellmy equation has been modified to include a cohesion (Bartelt et
al. 2015 [5]). Many materials, like mud and snow, do not exhibit a simple linear relation (µ = constant), see Figure 3-4. To model yield stress, we introduce the parameter N0. With this approach it is
possible to model ideal plastic materials. In this case N0 serves as a yield stress and µ a "hardening"
parameter. The new equation for the frictional resistance S is then
𝑆 = 𝜇𝑁 +

𝑁
𝜌𝑔𝒖2
−
+ (1 − 𝜇)𝑁0 − (1 − 𝜇)𝑁0 𝑒 𝑁0
𝜉

where N0 is the yield stress of the flowing material. Unlike a standard Mohr-Coulomb type relation
this formula ensures that S→0 when both N→0 and U→0. It increases the shear stress and therefore
causes the avalanche to stop earlier, depending on the value of N0 .
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Figure 3-4: Relation between normal and shear stress. Left: Yield stress N0 serves to increase the
shear stress for higher normal pressures. At low normal pressures
(small flow heights) the shear stress increases rapidly from S=0 to S=N0.
The slope of the ‘S vs N’ relation remains µ, when the normal pressures are large.
Right: If µ=0, we have a visco-plasic behaviour.

Curvature
Since Version 1.6.20, the normal force N includes centrifugal forces arising from the terrain curvature. We use the method proposed by Fischer et al. (2012) [6], which was specifically developed for
RAMMS. The centrifugal acceleration ƒ is both a function of the avalanche velocity and terrain curvature. The acceleration is calculated according to
𝑓 = 𝒖𝑲𝒖𝑇
The matrix K describes the track curvature in all directions, including the track “twist”. The
centrifugal force is then
𝐹 = 𝜌ℎ𝑓
which is added to the normal force N. Typically this increases the friction, causing the avalanche to
slow down in tortuous and twisted flow paths. It can change the location of the deposition once the
flow leaves the gully. Curvature may be activated/deactivated in the Run Simulation window (tab
Params) or via the menu ‘Help → Advanced… → Curvature’.

Friction parameters µ and ξ
RAMMS::AVALANCHE offers a constant and a variable calculation mode. If a calculation is done with
constant friction values, of course, no terrain undulations and forest areas are considered. Therefore, we suggest to use the variable friction values if possible. µ and ξ values are saved as ASCII files
(called MuXi-files) and can be easily imported in GIS-Software (e.g. ArcGIS)
The creation of a new MuXi-file is demonstrated in the exercise 3.5e “How to create a new MuXifile” on page 49.
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Automatic MuXi Procedure
First Step: RAMMS performs a terrain analysis, where slope angles and curvatures are analyzed, resulting in four classification classes: flat, open slope, channeled and gully, see example in Figure below.

Figure 3-5: Automatic terrain analysis in RAMMS
In the next step, RAMMS uses the classification from above together with forest information, global
parameters (return period and avalanche volume, see Figure 3-8) and altitude limits to assign the µ
and ξ values.

Figure 3-6: Automatic assigning of µ and ξ values to grid cells
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Altitude limits
The default altitude limits that are used in the Automatic MuXi Procedure, are 1000 and 1500
m.a.s.l., valid for the Alps.

Figure 3-7: Altitude limits for automatic MuXi procedure
The two altitude limits can be interpreted as follows:
•
•

Alt. Limit 1 (higher value): Tree line of your project region should be higher than this limit
Alt. Limit 2 (lower value): Snow line of your project region

Example altitude limits are provided (only suggestions, without warranty) in the table below:
Table 1: MuXi Altitude Limits, examples for different climatic regions
Regions
Alps
Bansko (BUL)
Pyrenees
Socchi (RUS)
Norway (West Coast)
Juneau (USA)
Wyoming (USA)
Chile (Santiago Region)
Himalaya (Manali, India)

RAMMS Altitude Limits
1500 / 1000
1500 / 1000
1700 / 1200
1700 / 1200
500 / 200
500 / 200
2000 / 1500
2500 / 2000
3000 / 2500

Climate
Tree line (m)
2100
2100
2200
2200
800
700
3000
3000
3500

Snow line (m)
1000
1000
1200
?
100
200?
1500?
2000
2000
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3.1.5 Global parameters
The friction values µ and ξ strongly depend on the global parameters return period and avalanche
volume (see MuXi-table on page 98). Therefore, an appropriate return period has to be defined and
the avalanche volume has to be checked under Input → Global Parameters prior to creating a new
MuXi-file (see Figure 3-8 and exercise “How to create a new MuXi-file” on page 49).

Figure 3-8: RAMMS global parameters.

3.1.6 Forest information
Forest information is not required for a successful simulation, but recommended, because the friction parameters strongly depend on forest information. Forest information can be provided as:
•
•

ESRI ASCII grid (0: no forest, 1: forest)
Polygon shapefile

If no such files are available, the user can draw a polygon shapefile in RAMMS and import it as forest
information (see section 3.5.3 on page 47).

3.1.7 Calculation parameters
Calculation parameters such as output name, simulation grid resolution, end time, time step etc. can
be changed interactively in the RAMMS Run Simulation Widget.
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3.2 Preferences
You can set your RAMMS preferences and place the necessary DEM (Digital Elevation Model) files as
well as the forest files, maps and georeferenced orthophotos you wish to use in the appropriate
folders defined in the preferences see Figure 3-9 and Figure 3-10 below. This is optional, you do not
have to use these folders.
Use Track → Preferences to open the RAMMS preferences window or click the button
resetting the general preferences use Help → Advanced… → Reset General Preferences.

Figure 3-9: General tab of RAMMS preferences.

. For

Figure 3-10: Avalanche tab of RAMMS
preferences.

General Tab
Setting

Purpose

Working Directory

Set your working directory. VERY IMPORTANT: DO NOT USE BLANKS
in the working directory path!
Set the folder where you place your georeferenced digital maps
(consists of a .tif file and a corresponding .tfw file (world-file).
Set the folder where you place your digital georeferenced orthophotos (aerial picture, consists of a .tif file and a corresponding .tfw file
(world-file).
Set the folder where you place the Digital Elevation Models (format
ASCII grid, see section 3.1.1 on page 21)
Set the folder where you place your forest-files (formats: ASCII grid
or polygon shapefile).

Map Directory
Orthophoto Directory

DEM Directory
FOREST directory
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Avalanche Tab
Setting

Purpose

Nr of colorbar colors

Set default nr of colorbar colors.

GIF-Animation Interval [s]

Set interval for GIF animation images.

Background Color

Set background color (greyscale between 0: black and 255: white).

Animation Delay [s]

Set animation delay to decelerate the animation speed.

The following exercise Working directory shows how to choose a new working directory. All further
settings can be changed in a similar manner. The settings are saved, until they are changed again
manually.

Exercise 3.2 : Working directory
Choosing the right working directory is very useful and saves a lot of time searching for files and
folders.
VERY IMPORTANT: Do NOT use blanks or special characters in the path names!

•
•

Click
(or use Track → Preferences or Ctrl+P) to open the RAMMS preferences window.
Click into the field Working directory. A window pops up where you can choose your new
working directory. Click OK in both windows. Do this also for other directories if necessary.

Figure 3-11: RAMMS preferences

Figure 3-12: Browse for the correct folder.
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3.3 Creating a new project
A new project is created with the RAMMS Project Wizard, shown in the exercise below. The Wizard consists of four steps:
Exercise 3.3: How to create a new project

•
•

Click
or Track → New... → Project Wizard to open the RAMMS Project Wizard.
The following window pops up.

Figure 3-13: RAMMS Project Wizard Step 1 of 4
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Continuation of exercise 3.3: How to create a new project
Step 1:
• Enter a project name (1)
• Add project details (2)
• The project location (3) suggested is the current working directory. To change the location, click into the Location field. A second window appears and you can browse for a different folder (see figure below)
VERY IMPORTANT: Do NOT use BLANKS or special characters in the project location path!
• Click Next (4)

1
2
3
4

Figure 3-14: Step 1 of the RAMMS Project Wizard
Project Information.

Figure 3-15: Window to browse for a new project
location.

Step 2:
• Locate your DEM-file (ASCII or GEOTIFF). Click into the corresponding field
to browse for the appropriate file (1).
• The grid resolution of your DEM-file is
shown in (2). Change the resolution, if
needed (bilinear interpolation).
• Click Next (3).

1
2
3

Figure 3-16: Step 2 of the RAMMS Project
Wizard: GIS Information.
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Continuation of exercise 3.3: How to create a new project
Step 3:
• RAMMS shows the coordinates of your DEM-file (1).
• Enter the X- and Y-coordinates of the lower left and upper right corner of your project
area, using any Cartesian coordinate system (e.g. the Swiss Coordinate System CH1903
LV03), as it is shown below for the Vallée de la Sionne area.
• You can clip the DEM by entering new boundary coordinates or by specifying a polygon
shapefile (2).
• Click Next (3).

1

2
3
Figure 3-17: Project coordinates: lower left and
upper right corner of project area.

Figure 3-18: Step 3 of the RAMMS Project
Wizard: Project Boundary Coordinates.

Step 4:
• Check the project summary.
• To make changes click Previous, to
create the project click Create Project.

Figure 3-19: Step 4 of the RAMMS Project
Wizard: Project Summary.
Project creation:
• The creation process can take a while. Different status bars will pop up and show the progress of the project creation process.
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The following files will be created in the project folder.

Figure 3-20: Created project files

Table 3.2: Listing of files and directories created with a new RAMMS::AVALANCHE project.
File / Folder

Purpose

doc (folder)

Folder containing input and output log files

logfiles (folder)

Project creation and calculation log files

dhm.tif

GEOTIFF grid with altitude values

dhm.sav

Compressed binary altitude information (used in RAMMS)

_.av2

Input file

_.dom

Calculation domain ASCII file

_.dom.shp

Calculation domain shapefile

_.dom.shx

Calculation domain shapefile

_.dom.dbf

Calculation domain shapefile

_.xyz

Topographic data used in RAMMS
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3.4 Working with the RAMMS GUI
Once the project is created, there are several useful tools which can be helpful when working
with RAMMS. They are explained in the sections and exercises below.

3.4.1 Open input- and output-files
The easiest way to open either input- or ouput-files is by using these toolbar buttons:

Figure 3-21: Toolbar button to open an input file. You can also use the menu Track → Open… →
Input File.

Figure 3-22: Toolbar button to open an output file. You can also use the menu Track → Open… →
Avalanche Simulation.

Recent-Menu
The menu Track → Recent… allows you to directly open your 10 last accessed files (input and output), without having to search for them.

3.4.2 Visualizing shapefiles, MuXi-files and domain-files
There are different ways to visualize your project files (shapefiles, MuXi-files, domain-files). In the
exercise below, we will show these possibilities.
Exercise 3.4a : Visualizing shapefiles, MuXi-files and domain-files
a. Files tab in the right panel:
•
•

Click on the Files tab in the right AVALANCHE panel.
In the file tree below, you will see your available project files (polygon shapefiles, MuXi ASCII
files and domain shapefiles.
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Figure 3-23: Files tab and available project files (file-tree, dashed red).
With the blue + button, files from external directories can be added
to the file-tree. Refresh the tree with the refresh-button.
•

Click the checkbox next to a filename and the file will be shown in your visualization.

Figure 3-24: Selected file (Release.shp) on the right is shown in the visualization.
•

You can select and visualize as many files as you like!

Shapefile properties
• Line thickness, color or linestyle can be adjusted for every individual shapefile. These properties are only saved within this RAMMS Session. Right-click on a filename and choose Shapefile properties:

28

CHAPTER 3: APPENDIX

Figure 3-25: Right-click menus Shapefile properties, Release properties, Import forest from shapefile,
Deposition analysis (only output) and Delete.

Figure 3-26: Use Shapefile properties to change line thickness, color or linestyle.
Release properties
• Please see section 3.5.1 on page 38 on how to specify release area properties.
Import forest from shapefile
• Please see section 3.5.3 on page 47 on how to import forest from a shapefile.
Deposition analysis
• This function is only available in output mode. Please see section 4.2.3 on page 65 on how to
do a deposition analysis.
Delete
• Delete a file from disk.

b. Adding files to the project
You can add files to the visualization using one of these options:
•

Add data: Use the button
or the menu ‘GIS – Add data’ to add a shapefile. If this shapefile is located outside of your project directory, it will be added to the files-tree.
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•

Add files from folder: Use the button
(Add files from external directory) below the filetree to add all the files from an external directory to the file-tree. These files are added during this RAMMS session. After you exit and restart RAMMS, you have to add the files again.

•

Drag & Drop: see next section.

c. Drag & Drop:
It’s possible to Drag & Drop the following files onto the main visualization window:
•
•
•
•
•

Input files (.av2)
Output files (.out.gz)
MuXi files (.asc)
Polygon shapefiles (.shp)
Domain shapefiles (.shp)

3.4.3 Hillshade visualization
Use Extras → Create Hillshade Image to create a hillshade visualization. For this we follow the instructions from ArcGIS at
https://desktop.arcgis.com/en/arcmap/10.3/tools/spatial-analyst-toolbox/how-hillshade-works.htm
to calculate the hillshade representation of your DEM, see Figures below.

Figure 3-27 DEM surface visualization (with shadows) after creating a new project in RAMMS
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Figure 3-28 Visualization after creating and adding the hillshade image to RAMMS

3.4.4 Changing maps and orthophotos (aerial images)
It is possible to change the map or orthophoto of a project anytime. Take into account, that the
corresponding .tfw-file (world-file) has to be in the same folder as the actual map (.tif). If this is not
the case, the map will not be found!
To check which map and orthophoto are currently loaded in the project, open the project input (or
output) log (Project → Input Log File). Next to map image and ortho image you will find the location
and name of the loaded map and image, respectively.
Exercise 3.4b : How to add or change maps and orthophotos
d. Add or change a map:
•
•

Go to Extras → Add/Change Map or click
.
If more than one map is found, the following window pops up, listing the maps found:
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Figure 3-29: Window to choose map image.

•

Information on the image cover ratio (Percent), image dimensions (X- and Y-Dim, pixel)
and size (in MB) are provided and might be a selection criterion.
Select the map you wish to add and click Load selected map.

e. Map not found:
• If the question "No map found, continue search?" appears, you either don’t have an appropriate map, the map-folder directory is set wrong or the map is saved in a different
folder. In the second case click Yes and choose the correct folder. A window pops up to
browse for the correct map location and file.
• Or click No to cancel search.

f.

Change orthophotos:
•

Go to Extras →Add/Change Image or click

.

3.4.5 Moving, resizing, rotating, viewing

Exercise 3.4c: Moving and resizing the model
a. Terrain model has a dimension of 100% or smaller:
•

By clicking on the arrow

the model can be moved and resized.

Figure 3-30: Active project with lines and corners for resizing.
•

To move the model without changing size or aspect ratio, move the cursor to the
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•

model and check if the cursor turns to . Then click and hold the left mouse button and drag the model to the desired position.
To resize the model without changing the aspect ratio, use the mouse wheel to zoom
in or out. Alternatively, you can resize the model by changing the percentage value in
the horizontal toolbar

.

b. Terrain model has a dimension > 100%:
•
•

All steps explained above are still possible.
In addition to this, the white hand right next to the rotation button becomes active as
well. After clicking on this so-called view pan button
the model.

, it is also possible to move

Exercise 3.4d: Rotating the model

After activating the rotation button

, the model can be rotated along the rotation axis,

by moving the cursor directly on one of the axes until the cursor changes from
wise a freehand rotation in any direction is possible.

to

. Other-

Figure 3-31: Active project with rotation axes.

Exercise 3.4e: How to switch between 2D and 3D mode

Click
to switch from 3D to 2D view. This button then changes to
will return to 3D view.

and by clicking again, you
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Figure 3-32: 3D view of example model.
Figure 3-33: 2D view of example model.
In 2D mode you have all possibilities that work for the 3D mode. It works for input files as well as
for simulations. For the following functions of RAMMS it is necessary to switch from 3D to 2D
view:
INPUT:

OUTPUT:

•

Draw new polygon shapefile

•

Draw new polygon shapefile

•

Release area information

•

Draw new line profile

•

Draw new domain

•

Measure distance and angle

•

Measure distance and angle

3.4.6 Colorbar
As soon as a parameter is shown in the project, the colorbar appears in the panel on the right
side of the main window. It can be turned on and off by clicking on
.
The colorbar can be moved anywhere in the screen (and can get lost). Use Project → Get
Colorbar to find a lost colorbar.

Exercise 3.4f: Editing the colorbar
Changing the minimum and maximum values of the colorbar as well as changing the number
of colors used is done in the panel AVALANCHE (right of the map window).

1

2
3

Figure 3-34 Colorbar and visualization properties
•
•

1) Simply type a new value into the respective field and hit the return key on the keyboard. The display will then be refreshed.
2) To view the underlying topography or image, you can change the transparency by en-
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•

tering a value or moving the slider.
3) Simulation contour lines: Contour lines of simulation results can be visualized.
Default contour levels are:
- Flow height (m): 1.0 2.0 3.0 5.0 10.0 (H_CONTOUR_LEVELS)
- Velocity (m/s): 1.0 5.0 10.0 20.0 30.0 40.0 50.0 (V_CONTOUR_LEVELS)
- Pressure (kPa): 1.0 3.0 10.0 30.0 100.0 (P_CONTOUR_LEVELS)

Figure 3-35: Simulation contour lines

You can change these contour levels by adding the following lines in the Add. Preferences (before the END tag):
Example:
H_CONTOUR_LEVELS 0.5 1.0 1.5 2.0
V_CONTOUR_LEVELS 5.0 10.0 50.0
P_CONTOUR_LEVELS 3.0 10.0 30.0
Changing colorbar color and position:
•

Open the editing window by either choosing

•

Edit → Colorbar Properties or clicking
in
the vertical toolbar.
To change the colorbar properties simply click
into the field you want to change, then click OK.

•

Under Edit → Colorbar White Color the textcolor of the colorbar can be changed to white.
This can be useful when changing the background color of your project to white Track →
Preferences → Avalanche Tab → Background
Color.

Figure 3-36: The Colorbar Properties
window.
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3.4.7 How to save input files and program settings
Once a project is created, it is saved under the name and location you entered during step 1 of
the RAMMS::AVALANCHE Project Wizard (see Figure 3-13 on page 23). The created input file has
the suffix *.av2.
The second situation, in which the input file is saved automatically, is when a calculation is started. The saved input file has the same name as the created output file.
Exercise 3.4g : How to save input files and program settings manually
a. Input file:
• In case you want to save the input file manually before running a calculation, go on Track
→ Save. This is helpful when a release area was loaded but you wish to close the project
before doing the simulation.
• If you wish to save a copy of your file under a new name, go to Track → Save
Copy As or click .
• A window pops up to choose an old file which should be overwritten or to type in a new
name, then click Save.
b. Program settings
• If you have moved and/or or rotated your project for a better view, you can save this position by going on Extras → Save Active Position.
• You can now get back to this position anytime by choosing Extras → Reload Position.
Exercise 3.4h : How to open an input file
•
•
•
•
•

Go to Track → Open → Input File, click
or use Ctrl+O.
A window opens to browse for a avalanche input file (*.av2).
Click Open after the file name was selected.
The project will be opened.
Alternatively, you can drag & drop the input file from your windows explorer onto the
RAMMS GUI.

Exercise 3.4i : How to visualize a shapefile

•
•
•
•

To load a shapefile go to GIS → Add data or click
.
A window opens to browse for a shapefile (*.shp).
Click Open after the file was selected.
Alternatively, you can drag & drop the shapefile from your windows explorer onto the
RAMMS GUI.
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Exercise 3.4j : How to open an output file/avalanche simulation
•
•
•
•
•

Go to Track → Open... → Avalanche Simulation, click
or use Ctrl+A.
A window opens to browse for an avalanche simulation file (*.out.gz)
Click OK
The simulation will be opened.
Alternatively, you can drag & drop the output file from your windows explorer onto the RAMMS
GUI.

3.4.8 About RAMMS
Some information about the RAMMS installation on your computer is found here: Help → About
RAMMS. If you click on the Info-Button left of the OK-Button, RAMMS will display the
RAMMS-License Agreement.

Figure 3-37: About RAMMS
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3.5 Running a simulation
To run a calculation or a specific scenario within a newly created project (creating a project see
section 3.3 on page 23) it is necessary to define
•
•
•

release area(s),
a calculation domain
and friction parameters µ and ξ.

The definitions of release area(s) and release heights as well as the set of friction parameters µ
and ξ have a strong impact on the results of RAMMS simulations, the definition of a smaller calculation domain is especially useful to keep the number of calculation grid cells as small as possible.
The exercises below show you how to create a release area, a calculation domain and a MuXi-file.
Details on the friction model used in RAMMS::AVALANCHE are given in section 0. on page 16.

3.5.1 Release area(s)
There are different possibilities to include release area(s) into the project. Since Version 1.7.0 it is
possible to specify more than one release shapefile. The following table gives an overview of the
possibilities RAMMS offers. For further explanations see the exercises below.
Create a new release area (polygon shapefile)

Open an existing polygon shapefile

If there is no release area available for your project, or you wish to create a new one, switch to
2D mode and click
(Draw new polygon shapefile)
Use the file-tree in the right-hand panel (Files)
and click the shapefile you want to visualize. Or,
use the ‘Add data’ button
or menu to visualize a shapefile from another source.

The definitions of release areas and release heights have a very strong impact on the results of
RAMMS simulations. Therefore, we recommend to use reference information such as photography,
GPS measurements or field maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area. Release areas can only be drawn in 2D mode.
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Exercise 3.5a : How to create a new release area (polygon shapefile)
•
•
•
•
•
•

Switch to 2D mode by clicking
.
Activate the project by clicking on the map once.
Click
(Draw new polygon shapefile).
Click into the project where you want to start drawing the outline of the release polygon.
Continue drawing the release polygon by moving the cursor and clicking the left mouse
button.
To end the release polygon, click the right mouse button. The polygon will be closed automatically.

Figure 3-38: Drawing a new release area.
Before the release area is created, you have to answer a few questions:
•
•

Add more polygon areas?
You can either answer with Yes and create a second release polygon as explained
above or answer with No and continue with the next step.
Choose a new polygon shapefile name:
Enter a new name for the polygon area.

The polygon area will now be created and opened directly, as well as the colorbar.
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Exercise 3.5b : How to visualize an existing release area (polygon shapefile)
Visualize shapefiles by clicking the checkbox next to the filenames in the file-tree (1, right panel), use the ‘Add data’ button (2) or drag & drop shapefile(s) from the Windows file explorer
onto the RAMMS topography.

2

1

Figure 3-39: How to visualize polygon shapefiles

In Figure 3-39 we selected two polygon shapefiles: 3Rel.shp, consisting of three polygons, and
2Rel.shp with two polygons. For every polygon, we can specify a release depth and/or release delay.
Not every polygon must contain a release depth, only the ones we want to release, see exercises
below.
Once polygon area(s) are created or loaded, you have to specify the release height(s). Switch to 2D
mode, choose Input → Release area... → Details/Edit release area, click the button
or right-click
the polygon shapefile in the Files-Tab and choose Release properties, and choose the release area
polygon by selecting it with the left mouse button. The appearing window (Figure 3-40) yields information about release area, mean slope angle, mean altitude and estimated release volume. And,
most importantly, the release height can be entered, see exercise below. Do this for every release
area you wish to release. You can specify one release area, or multiple release area(s), see exercise
below.
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Exercise 3.5c : Specify release depth(s) and view release information
•
•
•
•

Switch to 2D mode by clicking
.
Activate the project by clicking on the map once.
Click on the View/Edit release area button
(1), choose Input → Release area... →
Details/Edit release area or right-click the filename and choose Release properties.
Then click into the release area you want to get information on (2). A red polygon is
drawn around the selected release area. The following window appears:
1

2

Figure 3-40: View/Edit release area
•
•
•

Enter a release depth in the field Release depth d0 (m). The corresponding release volume is
updated automatically.
Additionally, the following release area parameter are shown: mean slope angle, mean altitude, projected area and inclined (real) area.
A release delay in (s) can be specified in the last line, see next Figure.

Remark: The estimated release volume is very accurate for the grid resolution of your input project.
If you calculate a different simulation resolution, the estimation can differ from the calculated release volume.
In Figure 3-40 we selected the northern-most polygon of the shapefile 3Rel.shp and assigned a
release depth of 0.5m.
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Let’s assign a release delay (secondary avalanche release) for one of the polygons in 3Rel.shp.
Therefore, we again click on
(1) and choose the middle polygon of 3Rel.shp (2), see Figure
3-41 below. We then specify a release depth of 0.3m and a delay of 10s (3).
1

2

3

Figure 3-41: About
We do not specify a release depth for the last polygon of 3Rel.shp.
In a next step we can specify a release height for one of the two polygons of shapefile 2Rel.shp,
see below.
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Figure 3-42: About

Figure 3-43: Release area and volume information
Additional release information is found in the Avalanche panel, tab Volumes, see Figure 3-43 above.

3.5.2 Calculation Domain
To reduce calculation time, you can specify a smaller calculation domain to reduce the number of
computational cells. By analyzing a calculation with a coarse grid (large cell size), e.g. with a cell size
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of 5 or 10 m, you get an idea where the flow path is situated and you can limit the calculation domain
to the area of interest.
Switch to 2D mode and choose Input → Calculation Domain... → Draw New Domain or click .
Now you can draw a polygon containing the area of interest similar to drawing a new release area
(see section “Release area(s)” on page 38). We strongly recommend using smaller calculation domains especially if you calculate with small cell sizes (e.g. < 5m).

Figure 3-44: Calculation domain in green encloses the area of interest and reduces calculation time in
comparison with the default rectangular domain which is automatically generated.

Exercise 3.5d : Finding an optimized calculation domain
•

Open your input file.
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•

Draw a rough calculation domain as explained above, see Figure 3-45 below.

Figure 3-45: Input file with big calculation domain
•
•
•

Do a rough calculation with a simulation resolution of 10m. Use constant µ and  values
of e.g. µ=0.2 and =2000.
Wait for the simulation to finish. The simulation result will be displayed.
Click the Max Flow Height button .

Figure 3-46: Max Flow Height of a 10m simulation with constant mu and xi
•
•
•

•
•

Click GIS → Export… → Create Envelope Shapefile
A question pops up: Use buffer?
Click Yes. We want to use the envelope shapefile as a calculation domain, and therefore
we want to buffer it a little bit. Click No if you want to have the exact Envelope Shapefile of your output result. Beware: the MIN-value of your colorbar will be used as the
lower limit for the Envelope Shapefile!
Choose a filename for the envelope shapefile (a name is proposed).
The created envelope shapefile is shown in the visualization as a dashed red line.
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Figure 3-47: Envelope shapefile of Max Flow Height extent
•
•

Switch back to the input file
Use Input → Calculation Domain… → Load Existing Domain to load your envelope
shapefile as a new calculation domain, see Figure 3-48 below.

Figure 3-48: Input file with optimized calculation domain (envelope shapefile)
•

Now redo your simulation with a simulation resolution of 5m and a MuXi-file.
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Figure 3-49: Max Flow Height result of a 5m simulation with variable MuXi-file
•

In this example, the much smaller new calculation domain saves 70% !!!!! of the
computational time.

3.5.3 Friction parameters µ and ξ
Forest area
It is sometimes necessary to take forest areas into account, when running a simulation with variable
friction parameters (µ and ξ). Beware: If your scenario is an extreme scenario, then it might not be
appropriate to use forest information, as a forest would be completely destroyed by an extreme avalanche.
There are different ways to consider forest information:
(1) Import a digital forest file (ASCII grid or forest shapefile): Use Input → Forest… → Import

Forest from SHAPEFILE or Input → Forest… → Import Forest from ASCII Grid.
(2) Draw a forest file manually: See exercise below.
Exercise 3.5d: How to create a FOREST file
•
•
•
•
•

Switch to 2D mode by clicking
.
Activate the project by clicking on the map once.
Click
or choose Input → Polygon Shapefile… → Draw New Polygon Shapefile.
Trace the forest outline by creating as many FOREST area polygons as necessary (proceed as in section “Release area(s)” on page 38) and name your new forest shapefile accordingly. The shapefile will be shown as a red dashed line in the GUI.
Then right-click the shapefile in the Files-tree and choose Import forest from shapefile,
see below.
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Figure 3-50: Import forest from shapefile
•
•
•

You are asked, if you want to import the created FOREST file into your project. Click yes,
if you want to use the newly created FOREST (ignore the next point in this case). Otherwise click no and import the FOREST file later, as explained in the next point.
Import the new FOREST shapefile: Choose Input → Forest… → Import Forest Area from
SHAPEFILE, then select your FOREST shapefile.
This new FOREST information is not automatically taken over in existing MuXi-files.
Therefore, recreate existing MuXi-files if needed. If you create a new MuXi-file with Input → Friction Values… → Create new MuXi File (Automatic Procedure), the forest will
now be considered.
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MuXi-file
In RAMMS::AVALANCHE you can automatically generate a µ and ξ file based on topographic data
analysis, forest information and global parameters. The following exercise shows how to create and
load MuXi-files for a RAMMS simulation with variable friction parameters.
Exercise 3.5e: How to create a new MuXi-file
•
•
•

Choose Input → Friction Values… → Create new MuXi File (Automatic Procedure)
or click the button
.
A window pops up where you have to define an appropriate return period and check
your avalanche volume. You can also define these global parameters under (Input →
Global Parameters, see more information on page 20 ).
In the following window (Automatic MuXi Procedure) you can enter a file name (optional). If you leave it empty, then RAMMS will use a default filename, e.g. L30 (for
Large avalanche, 30-year return period). Unless you know better, leave the values as
they are.

Figure 3-51: RAMMS Automatic MuXi Procedure.
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•
•

•
•

Click OK.
If this is the first MuXi-file for this project, or if you changed or removed a forest cover
or if you changed the altitude limits when entering the file name, RAMMS will start a
terrain classification. Otherwise, RAMMS will skip the terrain classification (the classification is saved in the file muxi_class.asc in the logfiles folder).
The MuXi-file will be visualized after its creation. The µ- and ξ-values are saved in two
ASCII-files (L30_mu.asc and L30_xi.asc respectively). Only the region within the calculation domain will be visualized.
You can switch between the release area (if already loaded), and the µ and ξ values in
the choose Visualization area in the avalanche panel.

Exercise 3.5f: How to load an existing MuXi-file
•
•
•

Choose Input → Friction Values… → Load existing MuXi File
A window opens to browse for an existing MuXi-file.
Click open and the file will be loaded.

3.5.4 How to run a calculation
To run a calculation you have to open a created project (section 3.3), load a release area (section
3.5.1), and a calculation domain (section 3.5.2). A MuXi-file is necessary as well. Below you find two
examples, one for running a constant calculation (constant release height and constant friction parameters µ and ξ) and one for using variable friction parameters..
Exercise 3.5g: How to run an avalanche calculation
•
•

To run a simulation choose Run → Run Avalanche Calculation or click
The RAMMS | Run Simulation window opens. Before clicking Run Simulation, you should
check the input parameters.

General Tab:
-

SCENARIO Name
(1) Scenario output name: Choose a meaningful output filename, add parameter information to
the filename to recognize the output file.
(2) Save Max Values Only: If you want to save disk space and if the max values are all you are interested in, then use this feature. After a simulation finished, all ASCII files (deposition, max
flowheight, max velocity and max pressure) are exported automatically. The simulation results cannot be visualized in RAMMS.

-

Additional Information
(3) Project name.
(4) Project info: Add valuable project information to this field.
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(5) Calculation domain.
(6) Digital elevation info: Digital elevation
model (DEM) file.
1
-

-

Stop Criteria
(7) Momentum stopping criterion, see section 4.2.6 on page 70.
(8) Center of mass stopping criterion, see
4.2.6 on page 70.

2
3
4
5
6

Remarks
(9) “Escape” and “Ctrl+R” can be used to
cancel resp. start a simulation.
(10) Check box Run in background: Option
to run simulations in background mode.
The RAMMS interface remains active
and allows the user to start e.g. new
simulations.

7
8

9
10
Figure 3-52 General Information
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Continuation of exercise 3.5g: How to run a constant avalanche calculation
Params Tab
-

Simulation Parameters
(1) Sim resolution: Suggested simulation resolution for large avalanches: 5m. For small avalanches,
you can try better resolutions, between 2–5m. If your DEM resolution
is different than your simulation
resolution, then RAMMS performs a
bilinear interpolation. High resolution grids will extend your calculation time.
(2) End time: Simulation end time. Default time = 300s.

1
2
3
4
5
6

(3) Dump-step: The dump-step interval
defines the resolution of the animation of your simulation but has no
effect on the simulation results.
Suggested: 2-5s.
(4) Density: Keep the default value for
density if no further information on
the avalanche density is available
(300 kg/m3).

-

Figure 3-53: Parameter Tab

Miscellaneous Parameters
(5) Obstacle/Dam File: Draw polygons of areas, where no avalanche-flow should pass (houses,
deflecting dams, obstacles). The flow is then deflected.
(6) Curvature: Switch Curvature On or Off. Since Version 1.6.20, the normal force N includes centrifugal forces arising from the terrain curvature. We use the method proposed by Fischer et
al. (2012) which was specifically developed for RAMMS. Typically, this increases the friction,
causing the flow to slow down in tortuous and twisted flow paths.
See https://ramms.slf.ch/en/modules/avalanche/theory/friction-parameters.html for more
information.
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Continuation of exercise 3.5g: How to run a constant avalanche calculation
Mu/Xi FRICTION PARAMETERS
(1) Constant: For a calculation with constant MuXivalues, click Constant. Enter µ and ξ values below.
Choose Help → RAMMS Manuals… → Friction Parameter Table (PDF) or see friction value table on page 98
for an idea of µ and ξ.

2
1

(2) Variable: For a calculation with variable MuXi-values
(recommended), click Variable. You should have created a MuXi-file before starting a variable MuXi calculation.

3

(3) Cohesion: For dry avalanches, values between 0100Pa are ok (suggested: 50Pa). For wet avalanches,
slightly higher values (up to 200Pa) can be used.
See
https://ramms.slf.ch/en/modules/avalanche/theory/f
riction-parameters.html for more information.
(4) Define additional MuXi areas: You can specify up to
two additional polygon areas where you can change
the MuXi-values. Make sure you have good reasons to
change the µ and ξ values there.

4

Figure 3-54: Friction values Mu and Xi.

RELEASE PARAMETERS
(1) Filename: List of all the release shapefiles in use.
(2) Volume (m3): The estimated release volume per
shapefile is indicated in the second row.

1

2

3

4

(3) Depth (m): Release depth per shapefile.
(4) Delay (s): Release delay per shapefile. In this example, the shapefile “secondrel.shp” has a start delay of
10s.

5

(5) Total Volume (m3): Sum of all the release volumes
from above.
(6) Run Simulation Button

6

Figure 3-55: Release information.
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Continuation of exercise 3.5g: How to run an avalanche calculation
Run Simulation
• Click run simulation (Figure 3-55)
• The following window appears, showing the status of the calculation (Figure 3-56)
General information of the simulation (1), output filename (2), starting the calculation (3), for
every dump step RAMMS outputs max flow height (Hmax) and velocity (Vmax) (4), moving
momentum (%, 5) as well as flow volume, outflow volume (if it exists) and numerical volume
loss.

1

2

3
4
5
6
Figure 3-56: Calculation status window.

Press any button
Figure 3-57: Background simulation mode window.
Press any button to close the DOS window.
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3.5.5 How to run BATCH calculations
If you want to start several simulations automatically (e.g. overnight) use Track → New… → Run
Batch Simulations. You can choose how many computational cores the Batch-Mode should use. It’s
even possible, to create a new directory for every single batch-simulation.
Please do the following to prepare input files for Batch-Simulations:
•
•
•

•

Open an input file from your project, and open the "Run Simulation" window (the big green
button on the left vertical toolbar).
In the "Run Simulation" window, go through all the tabs, and set all the necessary input specifications.
Then, instead of starting a simulation, click "Cancel" (this will close the "Run Simulation"
window), and then click the "Save Copy As" Button (or Track → Save Copy As), and save a
new input file (enter a meaningful name, .av2 file).
Do the procedure above for every scenario you want to calculate. Then start the batchprocess and choose your input file. You can also choose input files from different directories
(projects).

Figure 3-58: Batch-Simulations
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4

Results

Once the simulation is finished, the simulation as well as the output logfile (see Figure 4-3) are
opened in RAMMS. (if you ran the simulation in background mode, see Figure 3-57, click any button
inside the DOS window to close the window. Afterwards, open the simulation in RAMMS manually).

Figure 4-1: Main window in output mode.
If the avalanche flows out of the calculation domain, RAMMS shows an alert (Figure 4-2). To get reliable results you should enlarge your calculation domain (see section 3.5.2).

Figure 4-2: Outflow volume alert.
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4.1 Project information
Once a scenario within a specific project is calculated, it is possible to open the output logfile (in output mode) including project settings and information as well as calculation specifications. You can
open the project’s output log with Project →Output Log File. A window as shown in Figure 4-3
opens. This window provides information about your project and is the first thing to look at after
running a simulation to check your simulation results.

(1) Information on simulation time
and resolution. Be sure the
simulation stopped due to LOW
FLUX or CENTER of MASS. Otherwise the output TIME END
CONDITION informs you, that
your simulation stopped before
the avalanche reached the
stopping criterion you defined
for the simulation (see section
4.2.6 on page 70).
(2) Information
results.

on

1

2

simulation

(3) Input logfile (see Figure 4-4).

3

Figure 4-3: Output Logfile.
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The input logfile (included in the output logfile), however, can already be opened once a project is
created and before a simulation is performed.
There are two ways to view your project settings and information. First you can open your project’s
input logfile (or output logfile, in output mode), or you can check your project’s region extent and
area in the avalanche panel (region tab).

You can open the project’s input log file with
Project → Input Log File. The following window
opens:
This window provides information about all your
project’s input specifications, like number of
nodes and cells, release areas, which DEM was
used, the loaded map and orthophotos as well as
your global simulation parameters.

Figure 4-4: RAMMS Project Input Log file.

To view the project coordinates, click the region
tab in your avalanche panel. The region tab lists Xand Y-Coordinates of the lower left (minimal values) and upper right (maximal values) corner (these
are coordinates you entered when creating the
project) as well as the global minimum and maximum altitude (Z value). Additionally, the total region area is shown (in km2).

Figure 4-5: Region extent (X-, Y- and Zcoordinates, total projected area).
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4.2 Visualization and analysis of results
This section gives a short overview on what is possible in RAMMS to view and analyze the simulation
results. The interpretation of the results has to be done by an expert who is familiar with the local as
well as with the topographic and meteorological situation of the investigation area.
RAMMS is a model and each model is a simplification of reality, therefore the simulation results
should not be analyzed without questioning them. We strongly recommend that all users perform
sensitivity studies.

4.2.1 Visualize different parameters
The drop-down menu Results offers the following functions:
•
•
•
•

Flow Height
Flow Velocity
Flow Pressure
Flow Momentum

•
•
•
•
•

Max values (Height
, Velocity
, Pressure
DEM Adaptions (Add Deposition to DEM)
Flow Analysis (Summary of Moving Mass)
Friction Values (µ, ξ)
Cell area (m2)

, Momentum, Shear Stress)

These results are all visualized by a color-plot in the topography. See exercise “4.2a Displaying calculation values” below.
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Exercise 4.2a: Displaying calculation values
The maximum values of flow height, velocity and pressure give a good overview of the dimension of
the avalanche. You find them under
Results → Max values…
→ Max flow height
→ Max velocity
→ Max pressure

Figure 4-6: Results: Maximum values of flow height (left), velocity (middle) and pressure (right)
The flow height can be visualized exaggerated by a factor. Click Help → Advanced… →Additional
Preferences… →Edit to change the factor of the quasi 3D-visualization of the flow height under the
keyword EXAGGERATION.

Figure 4-7: Quasi 3D-Visualization of flow height (left: exaggeration 1; right: exaggeration 5).
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4.2.2 Line profile and time plot
In the horizontal toolbar you find two further functions:
•

Line Profile

•

Time Plot

Line profile
A line profile is a good alternative to the color plot if the avalanche snow height, velocity or pressure
should be known at a specific location. The graph shows the currently active parameter. Every line
profile is saved in the file profile.shp in the project directory. If you want to keep this line profile, you
have to save it, see exercise “4.2b How to draw a line profile” below.

Time plot
This function provides a time plot at a single point. This is helpful when it is of interest to know the
values and maximum values at a specific location (e.g. at a building, dam, or a tree) through time.
Every point is saved in the file point.shp and a point-info file point_info.txt is additionally saved in the
project directory. If you want to keep this point, you have to save it, see exercise “4.2c How to create
a time plot” below. The point-info file can be visualized with Extras → Point… → View Point Info File.
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Exercise 4.2b: How to draw a line profile
a) Draw a new line profile:
•

Switch to 2D mode by clicking

•

Activate the project by clicking on it once, then click
or choose Extras → Profile → Draw
New Line Profile
Define the line profile in the same way you specify a new release area. Finish the line profile
with a right-click on the mouse button.
A window opens, displaying the line profile.

•
•

Figure 4-8: Line profile plot.

•
•

−
−

Filled grey area
Red line

−
−

Black line
Bottom scale

active parameter (scale on left side).
active parameter (multiplied by 50) added to the track
profile (altitude, scale on the right side).
track profile (altitude, scale on the right side).
projected profile distance (in m).

If you change the active parameter, min or max values or the dump-step in RAMMS, the plot
is directly updated. You can also start the simulation and then watch the time variations in
your line profile plot.
It makes sense to either draw a profile line perpendicular to the flow direction or draw the
line along the flow path. Basically, every imaginable path is possible
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Continuation of exercise 4.2b: How to draw a line profile

Figure 4-9: Line profile perpendicular
to flow direction.
•
•

Figure 4-10: Line profile along
the flow direction.

To save the coordinates of the points belonging to the line profile, go on Extras → Profile → Save
Line Profile Points and enter a file name.
To save the line profile parameters (distance in m and the active parameter, e.g. the flow height in
m) at the current dump-step, go on Extras → Profile → Export Profile Plot Data and enter a file
name.
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Continuation of exercise 4.2b: How to draw a line profile
b) Load an existing line profile:
•

Switch to 2D view by clicking

•

Activate the project by clicking on it once and click
or choose Extras → Profile → Draw
New Line Profile
Click the middle mouse button once
A window pops up and you can browse for the line profile you wish to open

•
•

Exercise 4.2c: How to create a time plot
a) Select time plot point:
•
•
•

Click
or choose Extras → Point → Choose Point
Click into the map at the point where you want to create a time plot.
A window opens, displaying the time plot at the point of interest (active parameter vs. time).
Flowheight is always combined with Velocity, whereas Velocity, Pressure or Momentum are
always combined with Flowheight.

Figure 4-11: Time plot window.
•
•

To save the point coordinates, choose Extras → Point → Save point Location and enter a file
name
To save the time plot data (time in s and the active parameter, e.g. the flow height, for every
dump-step), choose Extras → Point → Export Point Plot Data and enter a file name.
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Continuation of exercise 4.2c: How to create a time plot
b) Load a time plot:
• To reopen the time plot graph window of the last selected point, go on Extras → Point →
Create Point Time Plot
•
•
•

To open an arbitrary time plot that was saved any time before, click
.
Click the middle mouse button once.
A window pops up and you can browse for the time plot file you wish to open.

c) Enter point coordinates and get a time plot:
• Go to Extras → Point → Enter Point Coordinates (X/Y)
• Enter X-coordinates of your point of interest. Click OK.
• Enter Y-coordinates of your point of interest. Click OK.
• The time plot opens.

4.2.3 Deposition analysis
A deposition analysis (flow height) for a region of interest (ROI) can be done in the following way:
•
•

right-click the shapefile you want to analyze
choose Deposition analysis
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Figure 4-12: Deposition analysis of region of interest.

Figure 4-13: Result of a deposition analysis. Total deposition volume (m3)
as well as some statistical values are shown (min, mean, max).
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4.2.4 Google Earth Export
You need to have the Google Earth Software installed on your PC/laptop, otherwise you cannot use
this feature. The use of Google Earth is for free.
It’s possible to export your result to Google Earth. The default settings are for Switzerland. If your
project region is within Switzerland, you are lucky, and all you have to do is visualize the result you
want, and then using Extras → Google Earth… → Export Result to Google Earth.

Figure 4-14: Left: Visualization in RAMMS; Right: Exported result in Google Earth (© Google Earth)
If your project region is not within Switzerland, then the following other projections are supported in
RAMMS:

•
•

UTM
State Plane

Click Extras → Google Earth… → Google Earth Option to open the following window:
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Figure 4-15: Google Earth Options. Choose Projection and Spheroid (Datum) of your project region
If you choose a UTM-projection, then it’s possible to set the parameters in the Projection Parameters
section. The section Google Earth View Parameters are parameters for the initial visualization in
Google Earth. Change them as you like.
The Figure below shows the drop-down menus for the Projection and the Spheroid (Datum) fields.
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Figure 4-16: Google Earth Projection and Spheroid (Datum) drop-down menus

Click the Help-Button
to get help about the projections and how to specify Zone, Spheroid and
Projection Parameters (only for UTM), such that your result is visualized correctly.
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4.2.5 Creating an image or a GIF animation
Image
It is possible to export your results as an image in different formats (e.g. .png, .jpg, .gif, .tif etc.).
Click
or choose Track → Export… → Image File and define a file name with the corresponding
extension. An image of the visible part in the viewer will then be exported.

GIF animation
Creating a GIF animation is only possible in output mode. Click
or choose Track → Export... → GIF
Animation. Enter a file name and location and wait until the simulation stopped. As soon as the simulation finished, the GIF animation file is saved. In the Preferences in the avalanche tab you can define the interval for the GIF animation (GIF animation interval [s]).

4.2.6 Stopping criteria
There are two stopping criteria available in RAMMS:
1. Standard stopping criterion: Momentum-based, “Percentage of total momentum (%)”
2. New stopping criterion: Center-of-mass based, “Center-of-Mass vel threshold (m/s)”

Figure 4-17: The two stopping criteria available in RAMMS
The stopping criteria can be changed when starting a new simulation, see also Figure 3-52 on page
51. You can define both stopping criteria, and the simulation will then stop when one of them is
reached, either the momentum- or the center-of-mass-criterion. In the following, both criteria are
explained in more details.

Momentum-based stopping criteria
In classical mechanics, momentum p (SI unit kgm/s, or, equivalently, Ns) is the product of the mass
and velocity of an object (p = mv). Threshold values between 1-10% are reasonable, but this is only a
suggestion and has to be empirically determined for each test case. For every dump-step, RAMMS
sums up the momenta of all grid cells (dump-step-sum), thus finding a maximum momentum sum
(max-momentum-sum). Then the dump-step-sum is compared to the max-momentum-sum. If this
percentage is smaller than a user defined threshold value (see Figure above and on page 51), RAMMS
aborts the simulation and the avalanche is regarded as stopped.
Stopping criteria with large threshold values (e.g. >10%) may result in unrealistic early stopping of a
simulation. Small threshold values however may lead to numerical diffusion of the simulation results
and very slow creeping of the avalanche material and velocity oscillations.
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To check the stopping of your simulation, click Results → Summary of Moving Mass. A window similar to Figure 4-18 opens which shows the summary of moving mass.

Figure 4-18: Summary of Moving Mass information windows
Whether or not an avalanche stops depends on terrain (slope angle in runout), total flow volume and
friction values and should always be evaluated by an expert. In case of doubt on how to choose
threshold values we recommend running a simulation with a 1% threshold and checking the summary of moving mass for numerical diffusion and analyzing the avalanche runout (flow height and
flow velocity) with time plots (section 4.2.2).

Figure 4-19: Stopping behaviour of a RAMMS simulation. Small threshold values may lead to unlikly slow
creeping of the material. In the example shown in the figure above the stopping criteria is set to 0%.
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Figure 4-20: Stopping behaviour of a RAMMS simulation. In this example threshold values <2% lead
to numerical diffusion of the simulation results. Threshold values between 3-5% seem to be
appropriate in this case.

Check the output logfile under Project → Output Logfile to verify your simulation stopped due to low
flux (see Figure 4-3 on page 57). Otherwise enlarge the end time of your simulation (see exercise
“Run a calculation” on page 50).

Center-of-mass stopping criteria
This stopping criterion was introduced in Version 1.8.0. The idea of this new stopping criterion is the
following: Following the center-of-mass (COM) of the flow. RAMMS is calculating the COM every 2s,
and from the covered distance the velocity, with which the COM is moving.
The user can define a velocity threshold (in m/s), see Figure 3-52 on page 51, and as soon as the COM
is moving slower than this threshold, RAMMS considers the flow as stopped. With this approach,
numerical diffusion and slow creeping movements at the front can be prevented.
This criterion should only be used, if you simulate one single avalanche problem (catchment). If you
define two or more release areas (for different catchments), then this approach makes no sense. In
this case, set the threshold value to zero. In any case it’s suggested to do simulations with and without the center-of-mass stopping criteria, and to critically analyze results.
During a calculation, the center-of-mass travel-speeds are also written to the standard-output (the
black DOS command prompt), see Figure below. You can open the standard-output-logfile with
Extras → View Simulation Standard Output Log.
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Figure 4-21: Center-of-mass travel speeds

4.3 Adding structures or deposition to DEM
The option to adding structures or deposition to DEM must be used with great care and should not
be used to design deflecting dams. Deflecting or catching dams can neither be designed directly with
RAMMS nor can the residual risk below dams be calculated directly with RAMMS. RAMMS takes important factors in dam design such as energy dissipation, dam geometry or snow deposits in front of
a dam not properly into account. Dams have to be designed using well known standard engineering
procedures, e.g. Johannesson et al. 2009 [1], Rudolf-Miklau and Sauermoser 2011 [2]. RAMMS is well
suited to calculate the key input factors for dam design such as flow height and velocity. The damoption should however only be used to try to visualize the influence of guiding or small deflection of
the avalanche mass. RAMMS cannot be used directly to evaluate if the height of a deflecting dam is
sufficient for a certain scenario or not (see explanations below).

4.3.1 Creating a dam
RAMS offers the possibility to simulate the presence of a deflecting dam by increasing the altitude at
the position where a dam is considered. This option helps the user to design mitigation structures
and to test its influence on potential flow paths near populated areas.
Exercise 4.3a: How to create a new DEM to simulate a dam
•
•
•
•
•

Create a polygon shapefile where a dam is supposed to be built (Figure 4-22).
Create a second, inner polygon, if you wish to have a two-stage dam.
Go on GIS → Add DAM to DEM…
You have two options… → Enter Relative Dam Height or …→ Enter Dam Elevation
You will be asked to “Open dam file (*.shp)”. Select the shapefile you want to use as the outer edge of the dam.
The question pops up, if you want to “Open 2nd dam shapefile (inner polygon)?”
→ Click No to continue with the next step
→ Click Yes to choose a 2nd dam file (*.shp).
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•
•
•

Next step is to enter the total elevation height or the total relative height of the dam in meters. This is the elevation of the dam crest.
If you loaded an outer polygon file, you will be asked to enter the intermediate height (m)
(height of the outer polygon file) as well.
Finally, you have to “Enter new XYZ name”. Your new XYZ-file with the topographic information, containing the “dam”, is created in your project directory.

Figure 4-22: Polygon area where a dam is
supposed to be built.

Figure 4-23: New DEM with dam at location
of polygon shapefile.

To run a simulation based on the newly created XYZ-file, all you have to do is to choose the new XYZ file in the Run Simulation window, see below:
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Figure 4-24: Select new XYZ-file with dam information.

Figure 4-25: Simulation without (left) and with (right) a dam.

While RAMMS is able to simulate the effect of a dam lying lateral to the direction of flow quite well,
there might occur numerical problems if a dam lies perpendicular to the direction of flow.
•

Because there is no energy dissipation due to collision with dams implemented in RAMMS,
unrealistically large flow velocities and flow heights may be simulated in front of a dam.
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•

The numerical solver used in RAMMS incorporates information from neighboring cells. The
effect of dams with only one
cell as dam side wall may therefore be difficult to simulate.

If you encounter problems with the
simulation of mitigation measures as
described, we suggest creating a DEM
Figure 4-26: Dam with gradually rising side walls.
including a dam in GIS, ideally using
progressively increasing side walls as shown in Figure 4-26.
The interpretation of RAMMS simulations including mitigation measures such as dams has to be
done by experts. In addition, we recommend to always check the simulation results with engineering
approaches.

4.3.2 Creating a new DEM with avalanche deposition
In case you wish to simulate an avalanche overflowing a previous avalanche, you should consider the
deposition of the previous avalanche, because the path of the second avalanche will be influenced by
the modified terrain. In RAMMS one has to assume that the deposits from an initial avalanche are
not entrained by a subsequent avalanche. To do this, in the output mode, users can select the option
Add Deposition to DEM to add the flow height of an avalanche to the DEM at any arbitrary dumpstep. A new xyz-file (with the updated topographic information) will be created.

Exercise 4.3b: How to add avalanche deposition to new DEM
•

•
•
•

The deposition height is the flow depth at the end of a simulation when the avalanche is
considered to have stopped moving (alternatively, earlier dump-steps may be used if there
are reasons to believe the flow should have stopped earlier). So first view the results at the
last time step or a different time step, if desired.
Go to Results → Add Deposition to DEM
Enter a new name for the new XYZ-file.
The new XYZ-file, containing the deposition information, is created. To run a simulation
based on this new XYZ-file, just choose the XYZ-file in the Run Simulation window, see Figure
4-24.
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5

Program overview

RAMMS is a windows-based program that relies on drop-down menus and dialog boxes to set the
model parameters, run calculations and view results. Toolbar buttons are also available and provide
short-cuts of the menu path; moving the cursor over a button results in a short explanation, appearing in a text box below the cursor (‘tooltip’). For functions not available in the current context, the
menus and buttons are deactivated and cannot be used.

5.1 The Graphical User Interface (GUI)
The graphical user interface (GUI) consists of menu bar, horizontal and vertical toolbar, main window, time step slider, right and left status bar, colorbar and panel, see Figure below. They will be
explained in the following sections.

Figure 5-1: Graphical user interface (GUI)
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5.1.1 The menu bars
Track
Similar to the Microsoft Windows File menu, Track is used to open, close, save, print, backup and
export files.
New…

Open…

• Project Wizard

Start a new project, guided by the wizard (Ctrl + w)

• Convert XYZ Data →
Raster Data

Convert regular or irregular XYZ data (e.g. laser scanning data) into
a raster grid (ESRI ASCII or GEOTIFF).

• Run BATCH simulations

Possibility to start simulations automatically (e.g. overnight) You
can choose how many computational cores the Batch-Mode
should use (quasi parallel simulations, saves computational time).

• Run BATCH simulations (from Folder)

Choose a folder with input files for a batch simulation (see above).

• Export ASCII Files
from Simulations
(Batch)

Automatically export all ASCII files (max height, max velocity, max
pressure, deposition) from multiple output files.

• Export ASCII Files
from Simulations
(from Folder, Batch)

Automatically export all ASCII files (max height, max velocity, max
pressure, deposition) from all output files from a folder.

• Input File

Open an existing input file (*.av2) (Ctrl + O)

• Avalanche Simulation

Open an existing avalanche simulation (*.out.gz) (Ctrl + A).

Close

Close active file (input or output)

Save

Save active file (Ctrl + S)

Save Copy As

Save a copy of the active file (e.g. test.av2) under a new name (e.g.
simulation1.av2, works only in input mode).

Export…

Backup…

• Image File

Create an image of the active window in a chosen format. You can
choose the desired image format using the file extension (e.g.
.png, .jpg, .gif, .tif, etc.).

• GIF Animation

Create a GIF animation (only in output mode). Change GIF animation interval (s) and delay (s) in the preferences.

• Backup RAMMS
Version

Make a backup of the current RAMMS Version.

• Backup Active Project

Backup your active project. The user will be asked if he/she wants
to include output files in the backup. This function is useful when
having problems with a simulation. Make a backup and send the
zip-file together with some explanations to ramms@slf.ch. Make
sure that all your input data (release area shapefiles, domain files,
etc…) is in the project folder.

• Backup User Defined
Files/Folders

Backup any folder or files you want.
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Preferences
Log files…

Change RAMMS preferences (Ctrl + P)

• RAMMS Logfile
(current)

Show active RAMMS logfile.

• RAMMS Logfile
(last session)

If RAMMS crashed, open this logfile and copy/paste the content
into an email to ramms@slf.ch.

Restart RAMMS

Restart RAMMS.

Exit

Exit RAMMS (Ctrl + Q).

Recent…

Shows a list of up to 10 of your recent input and output files.

Edit
This menu is used to edit colorbar, axes and dataspace properties.
Colorbar Properties

Edit the colorbar properties.

Get Colorbar

Get back your colorbar, if lost.

Dataspace Properties

Edit your dataspace properties.

Show Dataspace Axes

Shows or hides dataspace axes of the project region. The axes are only visible if the
background color is NOT set to black.

Colorbar White Color

Checkbox. If checked, the colorbar text-color is white (default), otherwise black.
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Input
Menu used to specify global parameters, calculation domain, release area, friction parameters and
forest cover. This menu is active only in input mode.
Global Parameters

Set return period and avalanche volume. These parameters
are used to calculate a friction MuXi-File.

Calculation
Domain…

• Draw New Domain

Draw a new calculation domain. The mouse cursor changes to
an arrow. Select points with the left mouse button, finish with
a right mouse button click (the final right mouse button click is
NOT a point of your calculation domain). This works only in 2D
mode. Choose points clockwise.

• Load Existing Domain

Load an existing calculation domain (*.shp). Any polygon
shapefile can be used as calculation domain (Ctrl+D).

• Draw New
Polygon Shapefile

This activates the button to draw new polygon shapefiles. The
mouse cursor changes to an arrow. Select points with the left
mouse button, finish with a right mouse button click (the final
right mouse button click is NOT a point of your polygon). This
works only in 2D mode. Choose points clockwise.

• Load Existing
Polygon Shapefile

Load an existing polygon shapefile.

• Details/Edit Release
Areas

The mouse cursor changes to an arrow and you can select a
release area to define the release depth and to view release
area information. This works only in 2D mode.

• Details/Edit Overlap
Release Areas

Same as above, but used for overlapping release areas.

• Show Active Forest
Cover

If forest is considered, the corresponding shapefile is displayed. If your project uses no forest cover at the moment,
RAMMS will tell you so.

• Import Forest Area
From SHAPEFIL

You can import any polygon shapefile using this function.

• Import Forest Area
From ASCII grid

If a forest ASCII grid is available, it can be imported using this
function (0 = no forest, 1 = forest).

• Remove Active Forest
Cover

Remove the active forest raster data from the project.

• Load an Existing MuXi
File

Load afore created MuXi-file (*_mu.asc or *_xi.asc).

• Create New MuXi File
(Automatic Procedure)

The DEM is analyzed, classified and according to altitude,
slope and curvature information, return period and avalanche
volume, a new MuXi-file is created.

• Show MuXi Classification

Shows the result of the MuXi-classification.

• Advanced… → Remove
MuXi Classification File

Remove the MuXi-classification file.

Polygon
Shapefile…

Release
Area…

Forest…

Friction
Values…
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Show
This menu enables and disables the different visualizations. A little arrow indicates if the visualization
is enabled or disabled.
Show Lights

Show/hide light effects

Show Grid

Show/hide computational grid

Show Map

Show map

Show Image

Show orthophoto/image

Show Visualization

Show/hide release area (input mode) or simulation results (output mode)

Show Arrow

OUTPUT | Show/hide point arrow of time plot

Show Colorbar

Show/hide colorbar

Show Velocity Arrow

OUTPUT | Show/hide velocity vectors

Show Domain

INPUT | Show/hide calculation domain

Run
This menu is active only in input mode.
Run Avalanche Calculation

Opens the Run Simulation window to change parameters and to start the calculation of an avalanche simulation (F8).
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Results
This menu contains the results functions and is only active in output mode.
Flow Height

Shows flow height of the avalanche every dump step.

Flow Velocity

Shows flow velocity of the avalanche for every dump
step.

Flow Pressure

Shows flow pressure of the avalanche for every dump
step.

Flow Momentum

Shows flow momentum of the avalanche for every
dump step.

Max Values…

• Max Flow Height

Displays the maximum flow height.

• Max Velocity

Displays the maximum velocity.

• Max Pressure

Displays the maximum pressure.

• Max Flow Momentum

Displays the maximum momentum.

• Max Shear Stress

Displays the maximum shear stress.

Add Deposition to DEM

Adds the deposition of an avalanche simulation to the
DEM. A new DEM file is created.

Summary of Moving Mass

Summarizes the Moving Mass.

Mu

Displays the friction parameter µ for this simulation.

Xi

Display the friction parameter ξ for this simulation.

Grid Cell Area

Display the grid cell area for each grid cell (m2).
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GIS
This menu contains miscellaneous GIS functions.
Add data (shapefiles, MuXi-ASCII files) to the visualization.

Add Data
Export …

• Result as Shapefile
• Result as Raster Data

Export the active result to an ESRI GIS shapefile for
later use in a GIS program.
Export the active result to a GEOTIFF (default) or ASCII
raster file..

• Envelope Shapefile

Create an envelope shapefile from the active result.

• Envelope Shapefile from
ASCII File

Create an envelope shapefile from an ASCII file. User
can specify an ASCII file (e.g. max flow height).

Add Dam to DEM

Adds a dam to the DEM. You have to specify relative dam height or absolute dam elevation.

Show Slope Angle (°)

Display the slope angles.

Show Curvature (1/m)

Display the curvatures.

Show Contour Plot

Display a contour plot.

Resample Slope/Curvature

Resamples slope/curvature plots to a user defined resolution.
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Extras

Add/Change or Remove map

Add or change the topographic map of your project. The maps can be located in your project directory, or in your distribution’s ‘Map’ folder,
see section 3.2 for details. If not, you can browse
for maps.

Add/Change or Remove Image

Add, change or remove the image used for visualization of your project. The images can be located in your project directory, or in your distribution’s ‘IMAGE’ folder, see section 3.2 for details. If not, you can browse for images.

Create Hillshade Image

This will calculate a hillshade visualization of
your DEM. It’s then saved as a TIFF image that
you can use in RAMMS.

Point …

Profile …

• Choose Interactively

This activates the button to select a point. The mouse
cursor changes to an arrow. Select the point with the
left mouse button. This works only in 2D mode.

• Enter Coordinates (X/Y)

Enter the coordinates of a point you are interested in.

• Create Time Plot

Create a time plot of a selected point.

• View Info File

View point info file.

• Save Point Location

Save point location as a point shapefile.

• Export Time Plot Data

Export time plot data as a txt-file.

• Draw New Line Profile

This activates the button to draw a line profile. The
mouse cursor changes to an arrow. Select the points of
the line profile with the left mouse button, finish with
a right mouse click. This works only in 2D mode.

• Save Line Profile Points

Save your line profile as a polyline shapefile.

• Export Line Profile Plot
Data

Export the line profile plot data as a txt-file.

Save Active Position

Save your current state of view, as well as the
enabled and disabled visualizations.

Reload Position

Reload your saved position.

Google Earth …

• Export Result to Google
Earth

This function exports release areas and your results to
Google Earth. If your project location is within Switzerland (default), you can use this function without
changing any parameters. If not, see Map Options.

• Map Options

Enter map options if you want to export your result
from a location outside of Switzerland

• Map Options Help

Get help about Google Earth Map Options.

View Input File

Opens the input file in a window.

View Simulation Standard
Output Log

Opens the simulations standard output log in a
window (the black DOS window you see when a
simulation is running).
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Project
This menu contains the project input and output logfiles.
Input Log File

Displays the input logfile.

Output Log File

Displays the output logfile. The input logfile is appended to the output logfile.

Open Project Folder (Windows
Explorer)

Opens project folder in Window Explorer from within RAMMS.

Help
RAMMS User Manual (pdf)

RAMMS User Manual in pdf format.

Friction Parameter Table
(pdf)

Table of MuXi friction values in pdf format.

RAMMS License Agreement

RAMMS License Agreement

RAMMS FAQ

Opens the RAMMS FAQ website at
https://ramms.slf.ch in a web browser.

RAMMS Website

Opens the RAMMS website at https://ramms.slf.ch in a
web browser.

Update...

Download RAMMS updates manually or directly from
the web.

Update…

• Web Update

Start web update procedure. RAMMS checks online if
there is an update available.

• Get Update Manually
(download to local folder)

Download the update to a local folder.

• Install Update from local
folder

Install the update from a local folder.
Edit your existing license file or add/register a new
license key (module).

Update/Register License Key
Advanced…

• Color Tables – View Available Color Tables

Choose a different type of color scheme for your
colorbar.

• Additional Preferences Edit

Only for experts. Please contact ramms@slf.ch if you
have questions about the additional preferences.

• Reset General Preferences

Reset your general preferences (working directory,
map directory etc.).
It is possible, that the Visual C++ Redistributable libraries for Visual Studio 2015 (x64) are not installed on
your PC/laptop. These libraries are needed to run
RAMMS. In case they are missing, you are not able to
run simulations. Run this function to install these
libraries (Admin privileges required).

• Install C++ Libraries
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• Logging
• AutoWebUpdate

• Hardware Rendering

• Curvature

• Technical Support Information
RAMMS Changelog
About RAMMS

Checkbox. Switch logging ON or OFF.
Checkbox. Switch AutoWebUpdate ON or OFF. If AutoWebUpdate is ON, then RAMMS will check for updates whenever you start RAMMS.
Checkbox. Switch hardware rendering ON or OFF. If
hardware rendering is switched ON, then all graphical
rendering is done by your hardware, otherwise by IDL
(RAMMS). It is suggested to switch hardware rendering
OFF.
Checkbox. Switch curvature ON or OFF. See section
3.1.4 on page 16 for more information about curvature. Default is ON.
If you have a problem using RAMMS, please send us
the information from the Technical Support Information together with any error screenshots from
RAMMS.
Show Information about the RAMMS releases in pdf
format.
About RAMMS information window.
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5.1.2 Horizontal toolbar
Project wizard: open avalanche wizard for creating a new avalanche project. (Ctrl + W)
Open input file. (Ctrl + O)
Open simulation. (Ctrl + A)
INPUT | Save copy as: save the active file under a new name.
INPUT and OUTPUT | Close: close the active file.
Print: displays the Windows print manager.
Undo, Redo.
Arrow (move and resize), Rotate, Move.
Simulation Results: Choose this function and move the arrow over the topography → x-,
y- and z-Coordinates of the mouse position are shown in the lower right status bar (see
Figure 5-11 on page 96).
OUTPUT | If you move the arrow over the simulation data, the active parameter is
shown as well (see Figure 5-11 on page 96). If you click once with the left mouse button at a point of interest, a new window pops up called ‘RAMMS::AVALANCHE Time Plot
<Active Parameter>’.
INPUT, 2D | Draw new polygon shapefile: specify new polygon-points by clicking the left
mouse button, finish with a right mouse click. The user is asked if he/she wants to draw
more polygons. At last, he/sh has to specify a new filename for the polygon shapefile.
INPUT, 2D |Draw new calculation domain: specify a new calculation domain polygon by
clicking with left mouse button, finish with a right mouse click. A dialog box will then ask
the user for a new domain name (e.g. domain), and a polygon shapefile is saved.
OUTPUT, 2D | Line Profile: Select the topography, until the Line-Profile-Button is active.
Click the button and then move the cursor to the start point of your profile. Click the left
mouse button and move the cursor to the next position of your profile. Finish with a
right mouse button click. A new window pops up called ‘RAMMS::AVALANCHE Line
Profile Plot Active Parameter’. This line profile plot is linked to your simulation. If you
change the parameter or if you change the max-value in the avalanche panel, the
changes are adapted in the line profile plot too. When animating the simulation, the line
profile is animated too.
2D |Measure distance and angle: Click with left mouse button; distance and angle between clicks is shown in the lower right status bar. Finish with a right mouse click.
INPUT, 2D | View and Edit Release Areas.
Zoom tools.
Annotation tools, text, line, rectangle, oval, polygon, freehand. They can be activated
and deactivated in the additional preferences.
Preferences → Advanced… → Edit → Annotations
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INPUT | Create new MuXi File (Automatic Procedure).
Analysis of the input DEM: Slope Angle, Curvature and Contour Plots. Remove visualization by clicking the button again.
OUTPUT | Show dump step values of the simulation result: Flow Height.
OUTPUT | Show maximum values of the simulation results: Max Flow Height, Max Flow
Velocity and Max Pressure.
OUTPUT, 2D |Create a time plot for the last point location.
OUTPUT | Export the results to ASCII grid.
Open project folder in Windows Explorer.
Add/change maps/orthophotos.
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5.1.3 Vertical toolbar
Add data to visualization (*.shp, *.asc).
OUTPUT | Switch to corresponding input file.
Show/hide lights.
Show/hide mesh.
INPUT | Show/hide release area (or active parameter).
OUTPUT | show/hide simulation.
Show/hide colorbar.
OUTPUT | Show/hide velocity vector arrow.
Show map.
Show image.
INPUT | Open Run Simulation window.
OUTPUT | Animate Simulation / Continue Simulation.
Stop/Pause Simulation (

).

OUTPUT | End Simulation: skip to last dump-step of simulation.
Create a screenshot of the main window.
OUTPUT | Create GIF animation.
Change RAMMS Additional Preferences.
Edit dataspace properties.
Change RAMMS preferences (e.g. working directory).
Change view to 2D / Change view to 3D (

).

Refresh visualization (if stuck).
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5.1.4 Main window

1

2

Figure 5-2: Main visualization window and information panel.
The RAMMS GUI (Graphical User Interface) consists of two main regions, see Figure 5-2:
1. Main visualization window
2. Information panel, see section below.

5.1.5 Panel
An AVALANCHE panel is displayed on the right side of the RAMMS GUI (Figure 5-2), and consists of
the display part, where visualization and colorbar settings can be set (MIN/MAX/COLORS and
TRANSPARENCY/CONTOURS, and four tabs (Files, General, Volumes and Region). Always confirm with
ENTER (return key) when changing a value! Additionally, the PARAMETER line states the visible parameter (e.g. Release height (m) in the Figure below, red box). Simulation contour lines can only be
shown for an output result (see Figure 3-35).
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Figure 5-3: AVALANCHE panel with four tabs
The Min and Max values as well as the number of colors influence directly the colorbar and the visualization. The transparency changes the visibility of the result: 0% means no transparency, 100%
means total transparency, see Figure below. The colorbar is divided into N (nr. of colors) different
colors.

Figure 5-4: No transparency (left) and 40% transparency (right) of simulation result.
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Files tab
The Files tab (Figure 5-5) shows a file tree with nodes for polygon shapefiles (Polygon, *.shp), MuXifiles (MuXi, *.asc) and calculation domain files (Domain, *.shp). See section 3.4.2 on page 27 on how
to use the Files tab.

Figure 5-5: Avalanche panel – Files tab
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General tab
The General tab (Figure 5-6) shows important simulation parameters, such as: nr. of nodes, nr. of
cells, end time (s), dump-step (s), grid resolution (m) and density (kg/m3). In input mode, for handling
and visualization purposes, the topographic information is resampled, such that there are only
~50’000 grid cells remaining (see Visualization Resampling Remarks below, red box). This does not
influence any simulation at all, it simply makes the users life easier to zoom and rotate the topography.

Figure 5-6: Avalanche panel – General tab
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Volumes tab
The Volumes tab (Figure 5-7) gives the user information about
•
•
•
•
•

projected release area (m2)
inclined (3D) release area (m2)
release volume (m3, estimated in input mode)
Flow volume (m3)
Outflow volume (m3), volume flowing out of the calculation domain

Figure 5-7: Avalanche panel – Volumes tab

Click the Update avalanche volume button (in output mode, red box), if the flow volume is not updated automatically.
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Region tab
The Region tab (Figure 5-8) gives information about min, max and diff X-, Y-coordinates and the altitude limits as well as information about the region area in km2.

Figure 5-8: Avalanche panel – Region tab

5.1.6 Time step slider
The time slider can be moved manually to change the active time (only in output mode).

Figure 5-9: The active time (20s) is shown in the time slider.

5.1.7 Left status bar
The left status bar is used to display status information for operations or informational messages
pertaining to the currently selected surface or manipulators.

Figure 5-10: Status information shown in the left status bar.

5.1.8 Right status bar
The right status bar is used to display the position of the cursor within the surface and additional
simulation results at the position of the cursor.
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Figure 5-11: Position information and simulation results in the right status bar.

5.1.9 Colorbar
In general, the colorbar appears at the right
edge of the main window (Figure 5-2) and
can be moved and resized (see section 3.4.6
on page 34).

Figure 5-12: Colorbar
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6

References and further reading
6.1 References
Maps and aerial images
➔ Topographic base maps and aerial images (Source: Federal Office of Topography)
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6.2 Publications
The development of RAMMS is based on scientific findings published in international scientific
journals. A list of the most important scientific publications about RAMMS and its applications
can be found on our homepage at http://ramms.slf.ch. Visit a module-page, and check the Publication-tab at the bottom of the page.
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7

Appendix
7.1 MuXi-Table

The following friction parameters (µ and ξ values) are used in RAMMS. Return period and volume
category can be changed in Input → Global Parameters.
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Third-Party Software
The following third-party software components are used in RAMMS:
7-zip:
•
•
•

We sometimes use 7za.exe to zip data.
7-zip is licensed under GNU LGPL.
The source code of 7-zip is available at www.7-zip.org.

Mtee:
•
•

Mtee is a Win32 console application that sends any data it receives to stdout and to any
number of files.
Mtee is released under MIT License https://ritchielawrence.github.io/mtee/.
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